User Guide for Project Managers and Translators
# Table of Contents

**About Wordfast Pro 3 help** ................................................................. 7
  Purpose ............................................................................................... 7
  Audience ............................................................................................ 7
  Organization ....................................................................................... 7
  Conventions ....................................................................................... 8
  Abbreviations and Acronyms .............................................................. 9

**About Wordfast Pro** ........................................................................ 11
  Overview ............................................................................................ 11
  Key advantages .................................................................................. 11
  Project Manager plug-in workflow ...................................................... 11
  TXML editor workflow ................................................................. 12

**Getting started with Wordfast Pro** .............................................. 13
  System requirements ........................................................................ 13
  Installing and activating Wordfast Pro 3 .......................................... 13
  Opening Wordfast Pro 3 .................................................................... 14
  Wordfast Pro 3 homepage .............................................................. 14

  Wordfast Pro homepage ..................................................................... 15
  PM perspective .................................................................................. 15
  TXML editor perspective ................................................................. 16

**Using PM plug-in** ........................................................................... 19
  Receiving files and conversion rules ................................................. 19
  Setting up filters .............................................................................. 19
    Selecting filter settings .................................................................... 21
    Viewing default file filters .............................................................. 22
    Adding new file filters .................................................................... 24
    Adding an Excel file filter ............................................................... 27
    Adding a PPT file filter .................................................................... 38
    Adding a Word file filter ................................................................. 39
    Selecting FrameMaker filter preferences ........................................ 40
    Adding an IDML Filter .................................................................... 42

  Analyzing files .................................................................................. 43
  Selecting Analysis output option ..................................................... 44
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analyzing files</td>
<td>45</td>
</tr>
<tr>
<td>Extracting frequents</td>
<td>51</td>
</tr>
<tr>
<td>Populating frequents</td>
<td>53</td>
</tr>
<tr>
<td>Cleaning up and updating translation memory</td>
<td>55</td>
</tr>
<tr>
<td>Pseudotranslation</td>
<td>58</td>
</tr>
<tr>
<td>Split/Merge TXML</td>
<td>62</td>
</tr>
<tr>
<td>Splitting TXML</td>
<td>63</td>
</tr>
<tr>
<td>Merge TXML</td>
<td>64</td>
</tr>
<tr>
<td>Bilingual Export</td>
<td>65</td>
</tr>
<tr>
<td>Export Only</td>
<td>66</td>
</tr>
<tr>
<td>Export files for review</td>
<td>68</td>
</tr>
<tr>
<td>Import reviewed files</td>
<td>70</td>
</tr>
<tr>
<td>Show/Hide 100%</td>
<td>72</td>
</tr>
<tr>
<td>Transcheck</td>
<td>75</td>
</tr>
<tr>
<td>Swap Source/Target</td>
<td>82</td>
</tr>
<tr>
<td><strong>TXML editor menu options</strong></td>
<td>85</td>
</tr>
<tr>
<td>TXML editor menu options</td>
<td>85</td>
</tr>
<tr>
<td>File</td>
<td>85</td>
</tr>
<tr>
<td>Edit</td>
<td>86</td>
</tr>
<tr>
<td>Translation Memory</td>
<td>88</td>
</tr>
<tr>
<td>Terminology</td>
<td>89</td>
</tr>
<tr>
<td>Window</td>
<td>90</td>
</tr>
<tr>
<td>Help</td>
<td>90</td>
</tr>
<tr>
<td><strong>Managing projects</strong></td>
<td>93</td>
</tr>
<tr>
<td>Creating or opening a project</td>
<td>93</td>
</tr>
<tr>
<td>Creating or opening a TM</td>
<td>97</td>
</tr>
<tr>
<td>Creating or opening a translation memory</td>
<td>97</td>
</tr>
<tr>
<td>Importing and exporting glossaries</td>
<td>110</td>
</tr>
<tr>
<td>Defining penalties</td>
<td>124</td>
</tr>
<tr>
<td>Defining color codes</td>
<td>126</td>
</tr>
<tr>
<td>Enabling spell check</td>
<td>130</td>
</tr>
</tbody>
</table>
Table of Contents

Translating in a project .................................................................................................................. 133
Opening a file ............................................................................................................................... 133
Translating a file .......................................................................................................................... 135
Finding and replacing content ..................................................................................................... 137
Enabling translation options ......................................................................................................... 139
Enabling Machine Translation ..................................................................................................... 141
Enabling Auto-Propagation ........................................................................................................... 147
Enabling Auto-Suggest .................................................................................................................. 148
Leveraging repetitive content ......................................................................................................... 150
Working with TM .......................................................................................................................... 153
Using Replaceables ....................................................................................................................... 155
Translation memory default color representation ................................................................. 155
Viewing TM leverage results ......................................................................................................... 156
TM Lookup default color representation ...................................................................................... 156
Using TM lookup ......................................................................................................................... 157
Working with terminology ............................................................................................................. 158
Highlighting terms ........................................................................................................................ 160
Working with tags .......................................................................................................................... 176
Editing source segment ............................................................................................................... 181
Using Transcheck ........................................................................................................................ 183
Confirming or Unconfirming segments ....................................................................................... 187
Using Outline window .................................................................................................................. 188
Viewing TXML Context ............................................................................................................... 190
Using notes ................................................................................................................................... 191
Viewing segment changes ............................................................................................................ 194
Saving a file ................................................................................................................................... 194
Closing a file .................................................................................................................................. 195
Using shortcut icons ..................................................................................................................... 195
Modifying colors and fonts ........................................................................................................... 198
Deleting a project .......................................................................................................................... 199

Working with advanced options .................................................................................................. 201
Selecting memory preferences ..................................................................................................... 201
Selecting AutoSave Preferences ................................................................................................. 202
Defining segmentation settings .................................................................................................... 204
Managing shortcut keys ................................................................................................................ 206
Managing licenses ......................................................................................................................... 214
Updating Wordfast Pro 3 dictionaries ......................................................................................... 215
Accented characters and shortcuts .......................................................... 217
Font mapping ......................................................................................... 219
Troubleshooting errors .......................................................................... 221
Working with Wordfast Aligner .............................................................. 227
  Working with Wordfast Aligner ............................................................ 227
  Using Wordfast Aligner ....................................................................... 227
  Basic Aligner menu options ................................................................. 230
  Using Alignershortcut icons ................................................................. 232
TM Administration perspective .............................................................. 235
  Using TM Administration perspective .................................................. 235
  Basic menu options ........................................................................... 245
  Using shortcut icons ........................................................................... 247
ABOUT WORDFAST PRO 3 HELP

Purpose
This online help will assist you in understanding and using Wordfast Professional (Wordfast Pro 3). It contains step-by-step procedures of Wordfast Pro 3 functions.

Audience
This help is a reference for project managers and translators. The audience must be familiar with basic translation terminologies.

Organization
The help is organized as follows:

<table>
<thead>
<tr>
<th>Section</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Section 1</td>
<td>Overview of Wordfast Pro 3 and workflows providing a snapshot of Wordfast Pro 3 functions.</td>
</tr>
<tr>
<td>Section 2</td>
<td>Procedure for installing Wordfast Pro 3.</td>
</tr>
<tr>
<td>Section 3</td>
<td>Procedures for opening Wordfast Pro 3 and a brief description of the PM and TXML editor perspectives.</td>
</tr>
<tr>
<td>Section 4</td>
<td>Procedures for PM plug-in tasks.</td>
</tr>
<tr>
<td>Section 5</td>
<td>Information on basic menu options.</td>
</tr>
<tr>
<td>Section 6</td>
<td>Procedures for managing translation projects.</td>
</tr>
<tr>
<td>Section 7</td>
<td>Information on advanced options such as selecting memory preferences, segmentation settings, shortcut keys, license management, updating dictionaries and working with accented characters.</td>
</tr>
<tr>
<td>Section 8</td>
<td>Information on common errors and their solutions.</td>
</tr>
<tr>
<td>Section 9</td>
<td>Procedures for working with Wordfast Aligner.</td>
</tr>
<tr>
<td>Section 10</td>
<td>Procedures for working with TM Administration perspective.</td>
</tr>
</tbody>
</table>
Conventions

- User actions are highlighted in **bold** to help understand the procedures better.
- Images are inserted at appropriate places to help you relate to the application interface.
- The term "**Note**" precedes any important information that you may need to know while performing a task.
- The word "Optional" follows procedural steps that are not mandatory.
# Abbreviations and Acronyms

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TM</td>
<td>Translation memory</td>
</tr>
<tr>
<td>TXML</td>
<td>Tracker Extensible Markup Language</td>
</tr>
<tr>
<td>XML</td>
<td>Extensible Markup Language</td>
</tr>
<tr>
<td>HTML</td>
<td>HyperText Markup Language</td>
</tr>
</tbody>
</table>
ABOUT WORDFAST PRO

OVERVIEW
Wordfast Pro 3 is a Java-based translation and editing application designed to improve the way in which translators work. It presents translators with a collaborative environment where translation memory (TM) files can be accessed quickly and efficiently. Wordfast Pro 3 is a flexible application that can work with desktop TM files or interact directly with a powerful TM server application. It can also operate as a stand-alone tool to supplement existing translation workflows.

KEY ADVANTAGES
The key advantages of Wordfast Pro 3 are as follows:

- **TM compatibility**: Tabular TM format allows for simple integration of Trados, SDLX, Translation Memory eXchange, or Déjà Vu TM files.
- **Format flexibility**: Native format is TXML, an XML-based pivot format. Filters exist for DOC, PPT, XLS, PDF, HTML, MIF, INX, JSP, RC, TMX, and TTX files. Wordfast Pro 3 supports only those TTX files that are translated and segmented using tag editor.
- **Collaborative environment**: Users can interact with TM Server and share translation memory assets in real-time.
- **Automated editing**: Multi-lingual spell checkers and terminology recognition improves the speed and accuracy in the review process.
- **Administrative security**: Managers can assign specific rights and privileges to individual translators or linguistic teams.

Wordfast Pro 3 provides an intuitive, collaborative environment where translators can deliver higher quality in-language content with greater consistency and efficiency.

PROJECT MANAGER PLUG-IN WORKFLOW

Find below the workflow diagram for PM plug-in:
**TXML Editor Workflow**

Find below the workflow diagram for TXML editor:
GETTING STARTED WITH WORDFAST PRO

This section includes basic information that will help you get started with Wordfast Pro 3.

- System requirements
- Installing and activating Wordfast Pro 3
- Opening Wordfast Pro 3
- Wordfast Pro 3 homepage

SYSTEM REQUIREMENTS

The minimum system requirements are:

- Operating system: Windows XP or higher, Windows 7, Windows 8.1, Mac OS 7 or higher (including OS X) or Linux
- Processor: 1.6 GHz
- RAM: 1GB
- Hard disk space: 200MB

INSTALLING AND ACTIVATING WORDFAST PRO 3

To install Wordfast Pro 3:

1. Download the Wordfast Pro 3 installer from the webpage http://www.wordfast.com/store_download.html to your PC.
2. Run the installer.
   The Wordfast Pro 3 Demo Mode appears.
   **Note:** Wordfast Pro 3 requires a Java JRE to be installed on your PC. During installation, if Java JRE does not exist, it will be installed for you. If it exists, then Wordfast Pro 3 will refer to it when running.
   In the Demo Mode, you can view and test all the functions of the software. You can purchase a Wordfast Pro 3 license from the webpage http://www.wordfast.com/store_download.html. If you do not purchase a license, you are limited to storing up to 500 translation units in your translation memories.

To activate a Wordfast Pro 3 license:

1. Purchase a Wordfast Pro 3 license from the webpage http://www.wordfast.com/store_download.html.
   The license file is sent to you via email.
2. Save the license file to a known location, preferably the Wordfast program folder.
3. Open Wordfast Pro 3.
4. Click **Help > License Management**.
   The Activation dialog box appears.
5. Click **License Manager**.
6. Select (Re-)Install a license certificate and click **Next**.
7. Browse and navigate to the folder where you saved the license file and select it.
8. Click Next twice and then Finish.

Your license is active. If you have any problems with the license and require support, please log into the Wordfast Pro 3 support hotline at www.wordfast.com.

**OPENING WORDFAST PRO 3**

To open Wordfast Pro 3, there are two options:

Double-click the Wordfast Pro 3 shortcut on the desktop.

Or

Go to **Start Menu > All Programs > Wordfast > Wordfast**.

The Wordfast Pro 3 homepage appears. Wordfast Pro opens in TXML Editor perspective.

**WORDFAST PRO 3 HOMEPAGE**

The Wordfast Pro 3 homepage is the workspace for translators to work on translation projects. The homepage directs you to two perspectives:

- **PM perspective**
- **TXML editor perspective**
## Wordfast Pro homepage

### PM perspective

Find below a sample PM perspective screenshot:

Find below the description for the various components of the PM perspective:

<table>
<thead>
<tr>
<th>Number</th>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>PM perspective icon</td>
<td>view the PM perspective. The PM perspective is the workspace for project managers to process files before and after translation. Refer to Using PM plug-in.</td>
</tr>
<tr>
<td>2</td>
<td>Analyze</td>
<td>analyze files for translation against a TM to leverage reusable content and pre-translate files. Refer to Analyzing files.</td>
</tr>
<tr>
<td>3</td>
<td>Extract frequents</td>
<td>extract recurring segments in the files. Refer to Extracting frequents.</td>
</tr>
<tr>
<td>4</td>
<td>Populate frequents</td>
<td>populates source TXML files with extracted recurring segments. Refer to Populating frequents.</td>
</tr>
<tr>
<td>5</td>
<td>Cleanup</td>
<td>clean up the file and update the TM after translation is complete. Refer to Cleaning up.</td>
</tr>
<tr>
<td>6</td>
<td>Pseudotranslation</td>
<td>copy source content to target. Pseudotranslated target content will have accented characters and the text will be expanded by 20%. This will help you preview what content will be selected as translatable and how complex formatting will appear in the target. Either source files or TXML files can be pseudotranslated. Refer to Pseudotranslate.</td>
</tr>
<tr>
<td>7</td>
<td>Split/Merge</td>
<td>split or merge a TXML file. The split options available are:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Split after selected number of TUs</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Split to selected number of parts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Split after selected number of word(s)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Refer to Split/Merge TXML.</td>
</tr>
<tr>
<td>8</td>
<td>Bilingual Export</td>
<td>export the TXML file into RTF format, edit using MS Word and import back the edited file. Refer to</td>
</tr>
</tbody>
</table>
### TXML Editor Perspective

Find below a sample TXML editor perspective screenshot:

![TXML Editor Perspective Screenshot]

Find below the description for the various components of the TXML editor perspective:

<table>
<thead>
<tr>
<th>Number</th>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Bilingual Export</td>
<td>show or hide 100% translation memory matches in the TXML file(s). Refer to Show/Hide 100% matches.</td>
</tr>
<tr>
<td>10</td>
<td>Transcheck/Revisions</td>
<td>check the translated content for missing tags, empty target, numbers, untranslated segment and/or terminology. Refer to Transcheck.</td>
</tr>
<tr>
<td>11</td>
<td>Swap Source/Target</td>
<td>swap source with target or vice versa. Refer to Swap Source/Target.</td>
</tr>
<tr>
<td>12</td>
<td>TM Preferences</td>
<td>create or open a translation memory.</td>
</tr>
<tr>
<td>Number</td>
<td>Use</td>
<td>to...</td>
</tr>
<tr>
<td>--------</td>
<td>----------------------------------</td>
<td>--------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1</td>
<td>Title bar</td>
<td>view the project name.</td>
</tr>
<tr>
<td>2</td>
<td>Menu bar</td>
<td>carry out all the functions, some of which are also included in the tool bar. Refer to TXML editor menu options.</td>
</tr>
<tr>
<td>3</td>
<td>Tool bar</td>
<td>quickly complete common functions. Point to the shortcut icon to see its function.</td>
</tr>
<tr>
<td>4</td>
<td>TXML perspective icon</td>
<td>view the TXML editor perspective. The TXML editor perspective is the workspace for managing translation projects. This perspective allows you to translate files by leveraging translation memory and terminology. Refer to Managing projects.</td>
</tr>
<tr>
<td>5</td>
<td>Main translation window</td>
<td>translate a file. This is the work space for translating files. Refer to Translating in a project.</td>
</tr>
<tr>
<td>6</td>
<td>TM Lookup window</td>
<td>view TM leverage results and context searching. You can either search for a term or a phrase and the source and target segments appear in a table format. Refer to Using TM Lookup window.</td>
</tr>
<tr>
<td>7</td>
<td>TXML Context</td>
<td>view the TXML context of the currently open file. Refer to Viewing TXML Context.</td>
</tr>
<tr>
<td>8</td>
<td>Notes</td>
<td>view, edit and delete notes specific to each segment. Refer to Using notes.</td>
</tr>
<tr>
<td>9</td>
<td>Segment Changes</td>
<td>view the segment changes in the currently open file. Refer to Viewing segment changes.</td>
</tr>
<tr>
<td>10</td>
<td>TXML Attributes</td>
<td>view the custom attributes applicable to a particular segment. To enable this tab, go to the Windows menu and click Show View &gt; Txml Attributes.</td>
</tr>
<tr>
<td>11</td>
<td>Outline window</td>
<td>quickly navigate a file from one source segment to another. Refer to Using Outline window.</td>
</tr>
</tbody>
</table>
Using PM plug-in

The Project Manager plug-in includes tasks that prepare files for translation. The preparation process includes the following tasks:

- Receiving files and conversion rules
- Setting up filters
- Analyzing files
- Extracting frequentss
- Populating frequentss
- Cleaning up and updating translation memory
- Pseudotranslate
- Split/Merge TXML
- Bilingual Export
- Show/Hide 100% matches
- Transcheck
- Swap Source/Target

Receiving files and conversion rules

This is the first step towards preparing files for translation. Find below a brief description of files and conversion rules:

- Files: These are received from clients for translation. They may be in any format, such as DOC, XLS, PPT, INX, HTML, JSP, and so on. When you open any one of these files in Wordfast Pro 3, it is automatically converted to TXML.
- Conversion rules: These rules are required for creating a new XML filter to convert XML files to TXML. The rules file is provided to you by the client.

Setting up filters

A filter defines the working parameters for different types of files received for translation. A filter can be selected from the available list or a new format created. Find below a list of available filters.

<table>
<thead>
<tr>
<th>Default Filter</th>
<th>Name</th>
<th>File type/extension</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ASP</td>
<td>Active Server Pages</td>
<td>.asp</td>
</tr>
<tr>
<td>Excel 2007</td>
<td>Microsoft Excel 2007 and 2010 documents</td>
<td>.xlsx, .xlsm</td>
</tr>
<tr>
<td>Default Filter</td>
<td>Name</td>
<td>File type/extension</td>
</tr>
<tr>
<td>----------------</td>
<td>---------------------------</td>
<td>---------------------</td>
</tr>
<tr>
<td>Excel</td>
<td>Microsoft Excel documents</td>
<td>.xls</td>
</tr>
<tr>
<td>HTM</td>
<td>HTM files</td>
<td>.htm</td>
</tr>
<tr>
<td>HTML</td>
<td>HTML files</td>
<td>.html</td>
</tr>
<tr>
<td>IDML</td>
<td>Adobe InDesign IDML files</td>
<td>.idml</td>
</tr>
<tr>
<td>INX</td>
<td>Adobe InDesign INX files</td>
<td>.inx</td>
</tr>
<tr>
<td>JSP</td>
<td>Java Server Pages</td>
<td>.jsp</td>
</tr>
<tr>
<td>Java Properties</td>
<td>Java.properties files</td>
<td>.properties</td>
</tr>
<tr>
<td>MIF</td>
<td>Adobe Frame Maker files</td>
<td>.mif</td>
</tr>
<tr>
<td>PDF</td>
<td>Adobe PDF files</td>
<td>.pdf</td>
</tr>
<tr>
<td>PowerPoint 2007</td>
<td>Microsoft PowerPoint 2007</td>
<td>.pptx</td>
</tr>
<tr>
<td>PowerPoint</td>
<td>Microsoft PowerPoint files</td>
<td>.ppt</td>
</tr>
<tr>
<td>RTF</td>
<td>Rich Text Format files</td>
<td>.rtf</td>
</tr>
<tr>
<td>SDLXLIFF</td>
<td>SDLXLIFF files</td>
<td>.sdlxliff</td>
</tr>
<tr>
<td>SRT</td>
<td>SubRip Text</td>
<td>.srt</td>
</tr>
<tr>
<td>TTX</td>
<td>TRADOS Bilingual files</td>
<td>.ttx</td>
</tr>
<tr>
<td>TXLF</td>
<td>Wordfast XLIFF files</td>
<td>.txlf</td>
</tr>
<tr>
<td>TXT</td>
<td>Text files</td>
<td>.txt</td>
</tr>
<tr>
<td>VDX</td>
<td>Microsoft Visio files</td>
<td>.vdx</td>
</tr>
<tr>
<td>Word 2007</td>
<td>Microsoft Word 2007 and 2010 files</td>
<td>.docx, .docm, .dot, .dotx</td>
</tr>
<tr>
<td>Word</td>
<td>Microsoft Word files</td>
<td>.doc</td>
</tr>
<tr>
<td>XLIFF</td>
<td>XLIFF files</td>
<td>.xlf, .xliff</td>
</tr>
<tr>
<td>XML</td>
<td>XML files</td>
<td>.xml</td>
</tr>
</tbody>
</table>

Please note that the process to add MS Excel files is different from the other file filters. Additionally, Wordfast Pro 3 supports only those TTX files that are translated and segmented using tag editor. The TTX files must be renamed to match the source format if they need to be viewed in tag editor.

Find below the procedures for the following tasks:
• **Selecting filter settings**
• **Viewing default file filters**
• **Adding new file filters**
• **Adding an Excel file filter**
• **Adding a PPT file filter**
• **Adding a Word file filter**
• **Selecting FrameMaker filter preferences**
• **Adding an IDML Filter**

**Selecting Filter Settings**

There are two common filter settings that can be enabled by navigating to **Edit > Preferences > Translations > Filters** as shown in the screenshot below.

- Numbers extraction: Select to extract all number-only segments to the translatable TXML file. Select to clear the checkbox, and to exclude number only segments to the translatable TXML file.
- Segmentation on break: Select to segment the text at every logical break such as period (.) or soft return.
VIEWING DEFAULT FILE FILTERS

A number of filters are pre-configured for your convenience. For example, if you choose the Default Java Properties Filter, the Encoding UTF-8 is automatically selected.

To view a default file filter:
1. Open Wordfast Pro 3 and click **Edit > Preferences > Translations > Filters > Formats.**

   The Formats dialog box appears. The default filters appear in the Available Formats box.

   ![Formats dialog box](image)

2. Select a default filter of your choice. For example, if you select Default HTML Filter, the options for HTML files appear in the Options box as shown below.
3. If required, you can modify the default options. Default filters cannot be removed.

**ADDING NEW FILE FILTERS**

If the filter of your choice is not available in the default option, you can add a new filter. For XML and Excel filters you will need to provide additional information.

Note: if a filter cannot be customized, it will not appear in the list of filters that can be added.

To add a new text-based (XML) filter:

1. Follow steps 1 and 2 from [Viewing default file filters](#).
   
   The Formats dialog box appears. The default filters appear in the Available formats box.

2. Click **New**.

   The New Format dialog box appears.
Using PM plug-in

3. Select the **Text based Filter Type** and click **OK**.

The New Text Based Filter appears in the Available Formats box.
4. Select the filter and click **Rename**, to change the filter name.
5. Select the **Encoding** as UTF-8.
6. Browse and select the **Conversion rules** file.

   **Note**: The conversion rules file includes commands describing the content to be translated in the XML files. Find below an example rules file.

---

**Example Rules File**

```
<rules>
  <rule>
    <command>translating
    <source>content_to_translate
    <target>translated_content
  </rule>
  ...
</rules>
```

---
7. Click **Apply** and **OK**.
   A new XML filter is set up.

**ADDING AN EXCEL FILE FILTER**

To add an Excel file filter:

1. Follow steps 1 and 2 from **Viewing default file filters**.
   The Formats dialog box appears. The default filters appear in the Available Formats box.
2. Select Format Type as Default Excel Filter.
   The Excel Filter options appear.
3. Click **Setup**.  
   The Choose Excel File... dialog box appears.
4. Select an Excel file and click **Open**.
   The Excel Column Selection Wizard appears.
5. Read the instructions carefully and click **Next**.

The Select Wizard type page appears.
6. Select the wizard type. You have two options:

   - Simple Wizard: selects all rows with content for translation
   - Advanced Wizard: allows you to choose the columns for translation. It also creates a Target column where the translated text will appear.

**Simple wizard**

To run the Simple wizard:

1. Follow steps 1 to 6 from Adding an Excel file filter.
2. Select Simple Wizard and click Next.

   The Preview page appears.
3. The content in the Preview page is selected for translation.

The Preview page models an Excel file. There are tabs corresponding to each Excel sheet. Each tab contains the following:

- Please choose number of preview rows drop down list: to choose the number of rows to be viewed
- Use headers check box: select checkbox, to select the Excel sheet headers as column header while selecting translatable content in the next step
- Table with the Excel sheet contents: select any row that should not be translated.

Click Finish.

The configuration and sample file path appears in the Formats options box as shown in the screenshot below.
- Select the **Translate Sheet Names** checkbox to include sheet names as translatable text.
- Select the **Translate hidden rows and columns** checkbox to include rows and columns hidden in the Excel file as translatable text.
- Select **Translate hidden sheets** to include hidden Excel sheets.
- Select the **Translate cell with formulas** checkbox to include cells with notes and formulas as translatable text.
- Select **Translate Data Validation comment** to include columns in the Excel sheet used to record comments validating the data, for example, columns recording vaccination data by date applied and dosage.
• Select the **Treat numbers stored in text format as real numbers** checkbox to include numbers as translatable text.

• Click **Apply** and **OK**.

An Excel file filter is set up.

**Note:** You can now directly open Excel files using this filter. While opening files you must choose the correct filter, when prompted. You can also rename the filter using the **Rename** button.

**Advanced wizard**

To run the Advanced wizard:

1. Follow steps 1 to 6 from [Adding an Excel file filter](#).
2. Select Advanced wizard and click **Next**.

The Preview page appears.

The Preview page models an Excel file. There are tabs corresponding to each Excel sheet. Each tab contains the following:

• Please choose number of preview rows drop down list: to choose the number of rows to be viewed

• Use headers check box: select checkbox, to select the Excel sheet headers as column header while selecting translatable content in the next step
Using PM plug-in

- Table with the Excel sheet contents: select any row that should not be translated.

  Click Next.

  The Selection page appears. If you have selected the Use header checkbox, the Excel sheet headers appear as column names.

  In the Translate column, select the columns for translation.

  The corresponding Column name appears in the Target column as shown in the screenshot below.

![Excel column selection wizard](image)

**Note:** The Target column includes names of columns where the translated text will appear.

- If you wish to select all columns in the currently open sheet, check Select all columns.
- If you wish to select all columns across all sheets, check the corresponding checkbox.

5. Click Next.

  The Regular expression page appears.
6. Enter a Regular Expression for the Excel analysis.
   **Note**: A regular expression provides a pattern to mark up any embedded HTML tags or variables in a column as tags.

7. Click **Finish**.
   The configuration and sample file path appears in the Formats Options box as shown in the screenshot below.
• Select the **Translate Sheet Names** checkbox to include sheet names as translatable text.

• Select the **Translate hidden rows and columns** checkbox to include rows and columns hidden in the Excel file as translatable text.

• Select **Translate hidden sheets** to include hidden Excel sheets.

• Select the **Translate cell with formulas** checkbox to include cells with notes and formulas as translatable text.

• Select **Translate Data Validation comment** to include columns in the Excel sheet used to record comments validating the data, for example, columns recording vaccination data by date applied and dosage.

• Select the **Treat numbers stored in text format as real numbers** checkbox to include numbers as translatable text.
8. Click **Apply** and **OK**.

An Excel file filter is set up.

**Note**: You can now directly open Excel files using this filter. While opening files you must choose the correct filter, when prompted. You can also rename the filter using the **Rename** button.

**Adding a PPT File Filter**

To add a PPT file filter:

1. Follow steps 1 and 2 from Viewing default file filters.

   The Formats dialog box appears. The default filters appear in the Available Formats box.

2. Select Format Type as Default PowerPoint Filter.

   The PowerPoint Filter options appear.
Using PM plug-in

3. Clear the Translate master slide checkbox to include master slide content as translatable text.
4. Clear the Translate Notes Pages checkbox to include notes as translatable text.
5. Click Apply and OK, to confirm the PPT filter preferences.

**ADDING A WORD FILE FILTER**

To add a Word file filter:

1. Follow steps 1 and 2 from Viewing default file filters.
   The Formats dialog box appears. The default filters appear in the Available formats box.
2. Select Format Type as Default Word Filter.
   The Word Filter options appear.
3. Enable the following options, if required:

<table>
<thead>
<tr>
<th>Select</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Translate hidden text</td>
<td>include hidden text as translatable text.</td>
</tr>
<tr>
<td>Accept track changes</td>
<td>include tracked changes as translatable text.</td>
</tr>
<tr>
<td>Translate index</td>
<td>include Index text as translatable text.</td>
</tr>
<tr>
<td>Translate smart tags</td>
<td>include smart tags as translatable text.</td>
</tr>
<tr>
<td>Ignore Bi-lingual styles</td>
<td>Ignore bilingual styles (Wordfast Classic/Trados Workbench-style files)</td>
</tr>
</tbody>
</table>

4. Click **Apply** and **OK**, to confirm the Word filter preferences.

**SELECTING FRAMEMAKER FILTER PREFERENCES**

The FrameMaker filter preferences must be set before using this filter option.

To set FrameMaker filter preferences:

1. Open Wordfast Pro 3 and click **Edit > Preferences > Translations > Filters > Formats**. The Formats dialog box appears. The default filters appear in the Available Formats box.

2. Select **Format Type as Default MIF Filter**. The FrameMaker Filter options appear.

   **Note**: The MIF versions supported are 7, 8, 9 and 10.
3. Select the required FrameMaker filter preferences. Translate Body Pages, Translate Master Pages, Translate Tab as Text are selected by default.

<table>
<thead>
<tr>
<th>Select</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Translate Body Pages</td>
<td>send body pages for translation</td>
</tr>
<tr>
<td>Translate Reference Pages</td>
<td>send reference pages for translation</td>
</tr>
<tr>
<td>Translate Master Pages</td>
<td>send master pages for translation</td>
</tr>
<tr>
<td>Translate</td>
<td>send text marked as variable for</td>
</tr>
<tr>
<td><strong>Select</strong></td>
<td><strong>to...</strong></td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Variable:</td>
<td>translation.</td>
</tr>
<tr>
<td>Translate Cross Reference:</td>
<td>send text marked as cross reference for translation</td>
</tr>
<tr>
<td>Translate Autonumber Formatting</td>
<td>send text with number formatting for translation.</td>
</tr>
<tr>
<td>Translate Tab as Text:</td>
<td>send text containing tab spaces for translation. If unchecked, a tag appears in the TXML instead of the tab.</td>
</tr>
<tr>
<td>Translate Discretionary Hyphen as Tag:</td>
<td>send text with discretionary hyphens for translation. Discretionary hyphens are part of the source language, and are removed by default. (Hard hyphens are always translated as tags in TXML extraction.) If unchecked, these hyphens will be removed from the file when sent for translation.</td>
</tr>
<tr>
<td>Translate Marker Types</td>
<td>send text marked with a FrameMaker marker type for translation.</td>
</tr>
</tbody>
</table>

4. Enter the Marker Type(s) that should be included in the translation.

5. Enter the Table IDs of the tables in the IDML that should be excluded in the translation.
   **Note**: Use comma-separated values for Table IDs that are to be included.

6. Click **Apply** and **OK**, to confirm the FrameMaker filter preferences.

**Adding an IDML Filter**

The InDesign (IDML) filter preferences must be set before using this filter option.

To set the IDML filter preferences:

1. Open TransStudio and click **Edit > Preferences > Translations > Filters Formats > IDML**.
   The Formats dialog box appears. The default filters appear in the Available Formats box.

2. Select Format Type as Default IDML Filter.
   The IDML Filter Preferences appear.
### Select to...

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Translate Line Break as Tag</td>
<td>add tags to line breaks, resulting in merged segments.</td>
</tr>
</tbody>
</table>

**Analyzing files**

In the Analyzing files process, files for translation are analyzed against a translation memory to leverage reusable content and pre-translate files. This process can greatly improve efficiency and reduce time and effort spent on translation. Find below the procedures for the following tasks:
• **Selecting Analysis output option**
• **Analyzing files**

**SELECTING ANALYSIS OUTPUT OPTION**

When a file is analyzed, an analysis output is generated in the same folder as the source files. The analysis output is the pretranslated TXML file. The analysis output options allow you to choose whether the pretranslated TXML file should be renamed to add the language suffix or placed in a separate folder with a language suffix or both.

To select analysis output option:

1. Open Wordfast Pro 3 and click [ ].
   The PM perspective appears.
2. Click **Edit > Preferences > Translations > PM Plug-in**.
   The Preferences (Filtered) PM Plug-in dialog box appears.

3. Select a condition to be followed when analyzing files. The options are as follows:
### Select to...

<table>
<thead>
<tr>
<th>Add language suffix</th>
<th>add the language code (for example ES_MX) as a suffix to the analysis output file. An example screenshot of the source folder and the source and analysis output file is given below.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subfolder creation</td>
<td>place the analysis output file within a subfolder. An example screenshot of the source and analysis output folder and file is given below.</td>
</tr>
<tr>
<td>Subfolder creation with language suffix</td>
<td>place the analysis output file within a subfolder. The subfolder and analysis output file will also include the language code as suffix. An example screenshot of the analysis output folder and file is given below.</td>
</tr>
</tbody>
</table>

### ANALYZING FILES

To analyze files:

1. Open Wordfast Pro 3 and click 📝. The PM perspective appears.
2. Click **Analyze**. The Analyze window appears.
3. Click to browse and select files from a folder. To add multiple files, press the Ctrl key and select the files. OR

Click to add an entire folder. Once a folder is selected, the following message appears.

Click Yes to add files recursively. This ensures that all files within a folder, including the files in the sub folders are added. The files appear. Files are selected by default when added.
4. The **Choose Format** Dialog box appears. Choose the format for the files to be analyzed. Only one format can be selected at a time.

![Choose Format Dialog Box](image)

**Note:** You can analyze up to 20 files at a time using Wordfast Pro 3 in Demo mode. If you want to analyze more files you will need to purchase the Wordfast Pro 3 license from www.wordfast.com.

5. Select one or more translation memories for analyzing the files.

**Note:** You will need to add at least one translation memory (TM) before analyzing files. To add a local or remote TM, click **TM Preferences**. Go to [Creating or opening a TM](#) for more information. You can click in the TM Options column header to sort the TMs in ascending or descending order. You can unselect all chosen TMs by clicking on **Unselect All**.

6. Select the following options if required:

<table>
<thead>
<tr>
<th>Select</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pretranslate</td>
<td>pretranslate the translatable segments and enter the percentage of TM matches.</td>
</tr>
</tbody>
</table>

**Note:** This is an optional step. The percentage defines
<table>
<thead>
<tr>
<th>Select</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the minimum leverage required to pre-translate a specific segment. You can also specify the analysis output option. For more information, refer <a href="#">Selecting Analysis output option</a>.</td>
<td></td>
</tr>
<tr>
<td>Copy all tags</td>
<td>from the source to the target segments for blank segments.</td>
</tr>
<tr>
<td>Copy Source on no match</td>
<td>copy source segments to target only for no match segments.</td>
</tr>
<tr>
<td>Calculate Internal Fuzzy Matches</td>
<td>calculate internal fuzzy matches in source files. For example, if there is a partial repetition of segments in a source file, it will be calculated as an internal fuzzy match. Select the percentage that should be calculated for such segments.</td>
</tr>
<tr>
<td>Include Internal Fuzzy matches as TM Matches</td>
<td>include internal repetitions as a TM match.</td>
</tr>
</tbody>
</table>

7. Select **format** for the output report. You have two options:
   - Output in CSV or XLS format: Select this option and click **Browse** to select a location and provide a file name as shown in the screenshot below.
8. Click **Save**, to save the CSV file. The **Analyze** window appears with the location of the CSV file as shown in the screenshot below.

Output only report summary: Select this option to view the output report on-screen

9. Click **Analyze**.

**Note:** When Excel files with sheetnames exceeding 31 characters are analyzed a warning message will appear. The warning message will prompt you to shorten the sheetnames that exceed 31 characters.

The analyzed TXML files are saved in the same folder as the source files. According to the output report format, either a CSV file is saved at the chosen location or the Analysis and Translation report appears as shown below. The report for files analyzed against separate TMs appears in separate tabs. The TM analysis report will display either % Segments or % Words based on the option selected in step 9 of **Selecting translation memory settings.**
### Analyze and Translation

**Start Analysis:** Thu Jun 13 13:44:42 MDT 2013  
**Translation Memory:** C:\\Test files\\LocalTM Demo\\LocalTM Demo DE.txt

**Analyze Total (4 files):**

<table>
<thead>
<tr>
<th>Match Types</th>
<th>Segments</th>
<th>Words</th>
<th>% Segment</th>
<th>Tags</th>
</tr>
</thead>
<tbody>
<tr>
<td>Golden</td>
<td>39</td>
<td>353</td>
<td>41</td>
<td>0</td>
</tr>
<tr>
<td>Leveraged</td>
<td>39</td>
<td>353</td>
<td>41</td>
<td>0</td>
</tr>
<tr>
<td>Repeateds</td>
<td>22</td>
<td>288</td>
<td>23</td>
<td>6</td>
</tr>
</tbody>
</table>

**TM Matches**

- 100%: 19 segments, 353 words, 41% tags  
- 95%-99%: 25 segments, 369 words, 26% tags  
- 85%-94%: 0 segments, 0 words, 0% tags  
- 75%-84%: 0 segments, 0 words, 0% tags  
- 50%-74%: 0 segments, 0 words, 0% tags  
- No Match: 10 segments, 50 words, 10% tags  

**Total:** 98 segments, 1100 words, 100% tags

**Chars/Word:** 5.98  
**Chars Total:** 6584

Analysis finished successfully without errors!

**Thu Jun 13 13:44:46 MDT 2013**

---

### Analyze and Translation

**Start Analysis:** Thu Jun 13 13:46:30 MDT 2013  
**Translation Memory:** C:\\Test files\\LocalTM Demo\\LocalTM Demo DE.txt

**Analyze Total (4 files):**

<table>
<thead>
<tr>
<th>Match Types</th>
<th>Segments</th>
<th>Words</th>
<th>% Word</th>
<th>Tags</th>
</tr>
</thead>
<tbody>
<tr>
<td>Golden</td>
<td>39</td>
<td>353</td>
<td>36</td>
<td>0</td>
</tr>
<tr>
<td>Leveraged</td>
<td>39</td>
<td>353</td>
<td>36</td>
<td>0</td>
</tr>
<tr>
<td>Repeateds</td>
<td>22</td>
<td>288</td>
<td>26</td>
<td>6</td>
</tr>
</tbody>
</table>

**TM Matches**

- 100%: 19 segments, 353 words, 36% tags  
- 95%-99%: 25 segments, 369 words, 34% tags  
- 85%-94%: 0 segments, 0 words, 0% tags  
- 75%-84%: 0 segments, 0 words, 0% tags  
- 50%-74%: 0 segments, 0 words, 0% tags  
- No Match: 10 segments, 50 words, 10% tags  

**Total:** 98 segments, 1100 words, 100% tags

**Chars/Word:** 5.98  
**Chars Total:** 6584

Analysis finished successfully without errors!

**Thu Jun 13 13:46:30 MDT 2013**
**Extracting frequents**

In the Extracting frequents process, repetitive source segments are extracted from the files for translation. Extracting frequents helps reduce the total number of segments to be translated. This is useful when translating in large jobs with many source files, containing repetitive content.

To extract frequents:

1. Open Wordfast Pro 3 and click . The PM perspective appears.
2. Click **Extract Frequents**. The Extract Frequents window appears.

3. Click  to browse and select files from a folder. To add multiple files, press the **Ctrl** key and select the files.

   **OR**

   Click  to add an entire folder. Once a folder is selected, the following message appears.

   ![PM Plugin Question](image)

   Click **Yes** to add files recursively. This ensures that all files within a folder, including the files in the sub folders are added.

   The files appear. Files are selected by default when added.
Note: Ensure all files selected or added are TXML files.

4. Under Extract files Options, select one of two options:
   Select Make a new file after (#) segments. Enter the maximum number of segments per file. The default is 250 segments. To produce only one frequents file, set the maximum number of segments per file to 10000.
   OR
   Select Make one frequents file per TXML.
   Note: The number signifies the minimum number of times a segment must be repeated in the set of files to be extracted. For example, if this value is 1, Wordfast Pro 3 will extract one unique occurrence of all segments that appear once or more.

   Note: Frequents will be extracted in the order in which the files were added.

5. Under Extract Location Options, select Extract Frequents to TXML folder to save the frequents file to the TXML folder.
   OR
   Select the radio button for Location, and browse to another location for the frequents file.

6. Under Extract Frequents Options, select Ignore exact matches from frequents analysis to ignore exact matches.
   Select Ignore numeric differences from frequents analysis to ignore numeric differences.

7. Click Extract.
   The repetitive segments are extracted and saved at the location selected.
Using PM plug-in

Note: The TXML files with extracted frequent segments are sent to the translator for translation. After translated files are received from the translators, they are cleaned up and saved into the TM. The TM is then applied to the original TXML files, to complete the translation process.

Populating frequents

In the Populating frequents process, the original TXML file is populated by the frequents file containing all translated content.

To populate frequents:

1. Extract frequents from the files as explained in Extracting frequents.
2. Open Wordfast Pro 3 and click .
   The PM perspective appears.
3. Click Populate frequents.
   The Populate Frequents window appears.
4. In the Select Frequents File panel, click to browse to the frequents file created by extracting frequents.
5. In the **Select Original TXML File** panel, add the source TXML file(s) for the frequents file.

Click 🗂️ to browse and select files from a folder. To add multiple files, press the **Ctrl** key and select the files.

OR

Click 🗂️ to add an entire folder. Once a folder is selected, the following message appears.

![PM Plugin Question](image)

Click **Yes** to add files recursively. This ensures that all files within a folder, including the files in the sub folders are added.

The files appear. Files are selected by default when added.

6. Click **Populate Frequents**.

When the process is complete, a confirmation message appears. The translated content from the frequents file populates the original source TXML file.
A sample of the Frequents Population Log appears below.

### Frequents Population Log

**Created on Thu Apr 03 15:34:15 MDT 2014**

![Populate Frequents](image)

To clean up and update TM:

**Cleaning up and updating translation memory**

After files are translated by the translator, they are sent back to the project manager. The PM then completes the final step of cleaning up the files and updating the TM. Cleaning up is an automated process, where the source segments are removed and the files are restored to their original format.

To clean up and update TM:
1. Open Wordfast Pro 3 and click  
   The PM perspective appears.
2. Click **Cleanup**.
   The Cleanup window appears.
3. Click to browse and select files from a folder. To add multiple files, press the Ctrl key and select the files.
   **OR**
   Click to add an entire folder. Once a folder is selected, the following message appears.

   ![PM Plugin Question]

   Click **Yes** to add files recursively. This ensures that all files within a folder, including the files in the sub folders are added.
   The files appear. Files are selected by default when added.
Using PM plug-in

Note: You can clean up to 20 files at a time using Wordfast Pro 3 in Demo mode. If you want to clean up more than files you will need to purchase the Wordfast Pro 3 license from www.wordfast.com.

4. Select Update TM check box for updating files to a TM. (Optional).

5. Select the translation memory.

Note: You will need to add at least one TM before cleaning up files. To add a local or remote TM, click TM Preferences. Go to Creating or opening a TM for more information.

6. Select an Update option. The options are as follows:

<table>
<thead>
<tr>
<th>Select</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overwrite if attributes are identical (default)</td>
<td>overwrite the existing translation unit only if custom attributes for new and existing translation units are identical.</td>
</tr>
<tr>
<td>Overwrite existing TU</td>
<td>overwrite the existing translation unit.</td>
</tr>
<tr>
<td>Do not overwrite TU</td>
<td>not overwrite existing translation unit.</td>
</tr>
<tr>
<td>Do not add to TM</td>
<td>not add to the translation memory.</td>
</tr>
</tbody>
</table>

7. Select Add Attributes checkbox, to enter custom attributes for the translation unit.

8. Select Add File Name as Attribute, to add file name as a custom attribute.

9. Select format for the output report. You have two options:

- Output in comma-separated format: Select this option and click Browse to select a location and provide a file name
- Output only report summary: Select this option to view the output report on-screen
10. Click **Cleanup**.

A Cleanup report appears.

---

**Pseudotranslation**

The Pseudotranslation option copies source content to target. Pseudotranslated target content will have accented characters and the text will be expanded by 20%. This will help you preview what content will be selected as translatable and how complex formatting will appear in the target. Either source files or TXML files can be pseudotranslated.

To pseudotranslate files:

1. Open Wordfast Pro 3 and click ![Clean up button](image). The PM perspective appears.
2. Click **Pseudotranslation**. The Pseudotranslation window appears.
3. Click  to browse and select files from a folder. To add multiple files, press the Ctrl key and select the files.

OR

Click  to add an entire folder. Once a folder is selected, the following message appears.

Click Yes to add files recursively. This ensures that all files within a folder, including the files in the sub folders are added.

The files appear. Files are selected by default when added.
4. The Choose Format dialog box appears. Choose the format for the files to be analyzed. Only one format can be selected at a time.

![Choose Format dialog box](image)

5. Click **OK**. The files appear.

6. **Note**: You can pseudotranslate up to 20 files at a time using Wordfast Pro 3 in Demo mode. If you want to pseudotranslate more than 20 files, you will need to purchase the Wordfast Pro 3 license from www.wordfast.com.

7. Select **Source** and **Target Language**.

8. Select **Create pseudotranslated target file** to create a pseudo translated file in the chosen language and source format. For example, if you pseudotranslate a Word document from English (US) to German (Germany), then the PM plugin will create a pseudotranslated TXML file and word document. These files will be placed in the same folder as the source file.

9. Click **Pseudotranslate**. The selected file(s) are pseudotranslated and the summary appears.
The pseudotranslated files are placed in the same folder as the source file. An example screenshot of the pseudotranslated TXML and source file are below.
Split/Merge TXML

The Split/Merge option can be used to split or merge a TXML file. The split options available are:

- Split after selected number of TUs
Using PM plug-in

- Split to selected number of parts
- Split after selected number of word(s)

To split/merge files:

1. Open Wordfast Pro 3 and click .
The PM perspective appears.
2. Click Split/Merge.
The Split/Merge window appears.

3. Click to browse and select files from a folder. To add multiple files, press the Ctrl key and select the files.
OR
Click to add an entire folder. Once a folder is selected, the following message appears.

Click Yes to add files recursively. This ensures that all files within a folder, including the files in the sub folders are added.
The files appear. Files are selected by default when added.
You can either split a TXML file or merge multiple TXML files.

**Splitting TXML**

To split a TXML file:

1. Select one of the files from uploaded folder as shown in the screenshot below.
The Split TXML option will be active.
2. Select one of the split options. TUs are rounded to the nearest block, to avoiding splitting into different files.

- Split after selected number of TUs (approx.)
- Split to selected number of parts (approx.)
- Split after selected number of word(s) (approx.)

Click **Split TXML**.

A confirmation message appears.

The TXML file is split, based on the selected Split options. Split files are saved with suffix -001, -002, et cetera, and placed in the same folder as the source file.

**MERGE TXML**

To merge two or more TXML files:

1. Select two or more files from uploaded folder as shown in the screenshot below.

The Merge TXML option will be active.
**Note:** You can merge up to 20 files at a time using Wordfast Pro 3 in Demo mode. If you want to merge more than 20 files you will need to purchase the Wordfast Pro 3 license from www.wordfast.com.

2. Click **Merge TXML**.
   The selected file(s) are merged.

The merged TXML files are placed in the same folder as the source files.

**Bilingual Export**

The Bilingual export option allows you to export the TXML file into DOC format, edit using Microsoft Word, and import back the edited file.

To complete bilingual export of files:

1. Open Wordfast Pro 3 and click .
   The PM perspective appears.

2. Click **Bilingual Export**.
   The Bilingual Export window appears.
3. Click to browse and select files from a folder. To add multiple files, press the Ctrl key and select the files.

OR

Click to add an entire folder. Once a folder is selected, the following message appears.

Click Yes to add files recursively. This ensures that all files within a folder, including the files in the sub folders are added.

The files appear. Files are selected by default when added.

You can either export the selected file(s), export for review or import the reviewed file(s).

**Export Only...**

The Export Only... feature allows you export TXML file(s) to Wordfast Classic (WFC).

To use export only:
1. Select the TXML file(s) from uploaded folder as shown in the screenshot below.

2. Click **Export Only**....
   The Select export type dialog box appears.

3. Select one of the following export types:
   - WFC bilingual - with placeholders
   - WFC bilingual - without placeholders
   - WFC bilingual - tag-content as placeholder
   - MS-Word table - without placeholders
   Click **Export**.
   The log appears. This log and the exported file in the chosen format are saved in the same folder as the selected TXML file(s).
To export files for review:

1. Select the TXML file(s) from uploaded folder as shown in the screenshot below.

2. Select the following create review options, if required:

<table>
<thead>
<tr>
<th>Select</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open log upon exit</td>
<td>generate a log of the export.</td>
</tr>
<tr>
<td>Exclude the notes column</td>
<td>exclude the notes content when the TXML file is exported to RTF.</td>
</tr>
<tr>
<td>Track changes</td>
<td>track changes in the RTF.</td>
</tr>
<tr>
<td>Protect document (word 2003 and above)</td>
<td>protect the file if using MS Word 2003 and above.</td>
</tr>
</tbody>
</table>

3. Click **Export Review**.

   The log appears. This log and the exported DOC are saved in the same folder as the selected TXML file(s).
4. To view the exported DOC, access the same folder where the selected TXML file(s) was located. An example screenshot of the exported DOC is given below.

![Example Screenshot of Exported DOC](image_url)
5. Complete the review of the file before importing the review back to Wordfast Pro 3.

**IMPORT REVIEWED FILES**

To import the reviewed DOC:

1. Click 📁 to browse and select specific files from a folder. To add multiple files, press the Ctrl key and select the files.
   OR
   Click 📁, to add an entire folder. Once a folder is selected, the following message appears.

   ![PM Plugin Question](image)

   Do you want to add files from subfolders?

   Click **Yes** to add files recursively. This ensures that all files within a folder, including the files in the subfolders, are added.

   The files appear.
2. Select the DOC file(s) as shown in the screenshot below.

3. Select the following merge review options, if required:

4. Click **Import Review**.

<table>
<thead>
<tr>
<th>Select</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open log upon exit</td>
<td>generate a log of the import.</td>
</tr>
<tr>
<td>Accept tracked changes</td>
<td>automatically accept the tracked changes.</td>
</tr>
<tr>
<td>Create Merged TXML</td>
<td>create a TXML document containing the merged files.</td>
</tr>
</tbody>
</table>

The log appears. The review changes are imported into a new TXML file with the suffix `.merge.txml`. Both the log and the `.merge.txml` file are saved in the same folder as the RTF file(s).
Show/Hide 100%

The Show/Hide 100% option allows you to hide or show 100% translation memory matches in the leveraged TXML file(s).

To hide 100% matches from the TXML file:

1. Open Wordfast Pro 3 and click . The PM perspective appears.
2. Click Show/Hide 100%. The Show/Hide 100% window appears.
3. Click to browse and select files from a folder. To add multiple files, press the Ctrl key and select the files.

OR

Click to add an entire folder. Once a folder is selected, the following message appears.

Click Yes to add files recursively. This ensures that all files within a folder, including the files in the sub folders are added.

The files appear. Files are selected by default when added.

Note: You can show/hide 100 % matches for 20 files at a time using Wordfast Pro 3 in Demo mode. If you want to do so for more than 20 files, you will need to purchase the Wordfast Pro 3 license from www.wordfast.com.

4. Click Hide 100% matches.

A summary appears. New TXML file(s) with the suffix .hidden.txml is saved at the same location as the source TXML file(s).
5. To show hidden 100% matches, add and select the hidden file(s) and click **Show Hidden**. A warning appears:

6. Select **Yes** to overwrite the files. Select **No** to skip the files. A summary appears. The hidden.txml files are overwritten.
**Transcheck**

The Transcheck option allows you to check the translated content for missing tags, empty target, numbers, untranslated segments, and/or terminology.

To transcheck TXML files:

1. Open Wordfast Pro 3 and click [Transcheck].
   The PM perspective appears.
2. Click **Transcheck**.
   The Transcheck window appears.
3. Click to browse and select files from a folder. To add multiple files, press the Ctrl key and select the files.

OR

Click to add an entire folder. Once a folder is selected, the following message appears.

Click Yes to add files recursively. This ensures that all files within a folder, including the files in the sub folders are added.

The files appear. Files are selected by default when added.
Note: You can check 20 files at a time using Wordfast Pro 3 in Demo mode. If you want to check more than 20 files, you will need to purchase the Wordfast Pro 3 license from www.wordfast.com.

4. Under Segment Changes/Transcheck Report options, select Add Notes column to report to add notes added to the segment in the TXML file.

5. Select the following Transcheck options, if required:

<table>
<thead>
<tr>
<th>Select</th>
<th>to check...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Partial Check</td>
<td>the character count between the source and target segments. Go to Edit &gt; Preferences &gt; Translations &gt;Transcheck&gt; Partial or click Configure to enter the minimum and maximum % of allowed character count for the target segment.</td>
</tr>
<tr>
<td>Empty target Check</td>
<td>for empty target segments.</td>
</tr>
<tr>
<td>Numerical Check</td>
<td>if the numerals in the source segment match the target segment. The numbers with hyphens will be read as two separate numbers. Click Configure to set the option in Preferences.</td>
</tr>
<tr>
<td>Tag Check</td>
<td>for missing tags in the target segments.</td>
</tr>
<tr>
<td>Forbidden Characters check</td>
<td>check if the target segment includes forbidden characters. Go to Edit &gt; Preferences &gt;</td>
</tr>
<tr>
<td>Select</td>
<td>to check...</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>Translations &gt;Transcheck&gt; Forbidden Characters or click Configure to add the forbidden characters that should not be included in the target segment.</td>
<td></td>
</tr>
<tr>
<td>Punctuations Check</td>
<td>for consistency in punctuation between source and target segments. Go to Edit &gt; Preferences &gt; Translations &gt;Transcheck&gt; Punctuations or click Configure to add the punctuation marks that should not be included in the target segment.</td>
</tr>
<tr>
<td>Untranslatable Check</td>
<td>if the untranslatable content in source and target segments is consistent. Go to Edit &gt; Preferences &gt; Translations &gt;Transcheck&gt; Untranslatable or click Configure to add untranslatable text that must be retained in the target segment.</td>
</tr>
<tr>
<td>Copied Source Check</td>
<td>if the source segment has been copied to the target segment.</td>
</tr>
<tr>
<td>Max Length Check</td>
<td>if the segment exceeds the maximum number of allowable characters (length).</td>
</tr>
<tr>
<td>First word capitalization Check</td>
<td>if the first word of each segment is capitalized.</td>
</tr>
<tr>
<td>Edited Exact match Check</td>
<td>if any exact match segments from the TM have been edited.</td>
</tr>
<tr>
<td>Unedited Fuzzy Match Check</td>
<td>if any fuzzy match segments from the TM have been left unedited.</td>
</tr>
<tr>
<td>Source Consistency Check</td>
<td>consistency between source segments if the target is repeated.</td>
</tr>
<tr>
<td>Target Consistency Check</td>
<td>consistency between target segments if the source is repeated.</td>
</tr>
<tr>
<td>Terminology Check</td>
<td>if the terms in the source segment are translated correctly based on the glossary.</td>
</tr>
<tr>
<td>Blacklist check</td>
<td>if any terms in the translation are blacklisted.</td>
</tr>
</tbody>
</table>

6. If Terminology Check is enabled, a glossary must be selected. To select a glossary:
Click the **Glossary** list tab. Select one or more glossaries from the list of glossaries.

To create or add another glossary, click **Glossary list preference** to go to Preferences.

7. If Blacklist check is enabled, a blacklist must be selected. To select a blacklist:
• Click the Blacklist tab and select a blacklist from the list. OR Click Blacklist List Preferences to browse to a blacklist.

![Blacklist List Preferences](image)

Select desired blacklist

<table>
<thead>
<tr>
<th>Blacklist Name</th>
<th>Target</th>
</tr>
</thead>
<tbody>
<tr>
<td>BlackList.txt</td>
<td>German</td>
</tr>
<tr>
<td>blacklist_en.txt</td>
<td>German (Ger...</td>
</tr>
<tr>
<td>en-de-Blacklist</td>
<td>German (Ger...</td>
</tr>
<tr>
<td>gl-projdi49.translations.com-Blacklist</td>
<td>German (Ger...</td>
</tr>
</tbody>
</table>

• If the TXML language and glossary language do not match, the following dialog box appears:

![Error](image)

Selected TXML language and Glossary language do not match for Terminology Check.
Please select matching language pair glossary from the list.

Select the correct TXML language and glossary language match from the list.

8. Click Transcheck.

The TransCheck Error Report appears. An example is given below.

![TransCheck Error Report](image)

**TransCheck Error Report**

Centralization of Localization1.doc.txml.doc.txml

<table>
<thead>
<tr>
<th>Tag Check</th>
<th>Block ID</th>
<th>Source</th>
<th>Target</th>
<th>Notes</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Segment ID 3</td>
<td>2:1</td>
<td></td>
<td></td>
<td>[31] Please edit the translation in the TARGET column directly.</td>
<td>Tags (2) from source are missing from target.</td>
</tr>
<tr>
<td>Segment ID 4</td>
<td>3:1</td>
<td></td>
<td></td>
<td>[32] To comment on a segment, simply create a new MS Word comment.</td>
<td>Tags (2) from source are missing from target.</td>
</tr>
<tr>
<td>Segment ID 5</td>
<td>4:1</td>
<td></td>
<td></td>
<td>[33] Codes such as [31], [32], etc. are keys that handle formatting and functions.</td>
<td>Tags (2) from source are missing from target.</td>
</tr>
<tr>
<td>Segment ID 6</td>
<td>4:2</td>
<td></td>
<td></td>
<td>DO NOT remove any codes like this, ADD these codes to the translation at the corresponding points in the text.</td>
<td>Tags (2) from source are missing from target.</td>
</tr>
<tr>
<td>Segment ID 7</td>
<td>5:1</td>
<td></td>
<td></td>
<td>[34] It is best to edit this file in Normal view rather than Page Layout.</td>
<td>Tags (2) from source are missing from target.</td>
</tr>
<tr>
<td>Segment ID 8</td>
<td>6:1</td>
<td></td>
<td></td>
<td>[35] DO NOT alter the source column text or any other part of this file.</td>
<td>Tags (2) from source are missing from target.</td>
</tr>
</tbody>
</table>

**Note**: The TransCheck Error Report is saved automatically as an html file in the same folder as the TXML file, with the following prefix: TranscheckError_date-time.html.
Note: The Unedited Fuzzy Check report includes the score for the segment. An example is shown below.

TransCheck Error Report

Demo-Sample-Eng1.docx.txml

<table>
<thead>
<tr>
<th>Segment ID</th>
<th>Block ID</th>
<th>Source</th>
<th>Target</th>
<th>Score</th>
<th>Notes</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0:1</td>
<td>1(1)(a)(1)(2)System testing is performed on (1)The Prüfung des Systems wird auf dem Online the online system in the context of a function which System in Zusammenhang mit einer System Requirement Specification(s) (FRS) and/ oder einer Systemanforderung (SRS).</td>
<td>99</td>
<td>Segment contains unedited fuzzy match.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Export notes

The Export Notes function allows you to export notes in a separate Word file.

To export notes as a Word file, click Export Notes.

The notes are exported in a Word table. By default, the notes are saved in the same folder as the TXML file.

An example of exported notes is given below.

<table>
<thead>
<tr>
<th>ID</th>
<th>Source</th>
<th>Target</th>
<th>Type</th>
<th>Notes</th>
<th>Creator ID</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>INTERNET SECURITY</td>
<td>INTERNETSICHERHEIT</td>
<td>text</td>
<td>this is a note</td>
<td>cjacques</td>
<td>Mon Nov 04 11:47:38 MST 2013</td>
</tr>
<tr>
<td>7</td>
<td>A personal firewall is an application which controls network traffic to and from a computer, permitting or denying communications based on a security policy.</td>
<td>Eine Personal Firewall ist eine Anwendung, welche den Netzwerkverkehr zu und vom Computer steuert. Auf einer Sicherheitsrichtlinie basierende Kommunikation wird zugelassen oder verweigert.</td>
<td>text</td>
<td>another note</td>
<td>cjacques</td>
<td>Mon Nov 04 11:53:30 MST 2013</td>
</tr>
</tbody>
</table>

Segment Changes Report

The Segment Changes report enables you to export segment changes in a separate TXML file.

To generate a Segment Changes report, click Segment Changes on the Transcheck tab.

The following message appears:
If there are no segment changes, the following message appears:

By default the report is saved in the same folder as the TXML files.

A sample report appears below.

**Segment Changes Report**

**Demo_Glossary_en-de.txt.xml**

<table>
<thead>
<tr>
<th>Source revision</th>
<th>Source</th>
<th>Source</th>
<th>Target</th>
<th>User</th>
<th>Date/Time</th>
<th>Notes</th>
</tr>
</thead>
</table>

**Swap Source/Target**

The Swap Source/Target option allows you to swap source with target or vice versa.

To swap source/target:
1. Open Wordfast Pro 3 and click 📚.
   The PM perspective appears.
2. Click **Swap Source/Target**.
   The Swap Source/Target window appears.
3. Click 📚 to browse and select files from a folder. To add multiple files, press the Ctrl key and select the files.
   OR
   Click 📚 to add an entire folder. Once a folder is selected, the following message appears.

   ![PM Plugin Question](image)

   Click **Yes** to add files recursively. This ensures that all files within a folder, including the files in the sub folders are added.
   The files appear. Files are selected by default when added.
**Note**: You can swap up to 20 files at a time using Wordfast Pro 3 in Demo mode. If you want to swap more than 20 files, you will need to purchase the Wordfast Pro 3 license from www.wordfast.com.

4. Click **Swap Source/Target**.

A summary appears. New TXML file(s) with the suffix .swapped.xml is saved at the same location as the source TXML file(s).
**TXML editor menu options**

The Wordfast Pro 3 basic menu options are as follows:

- **File**
- **Edit**
- **Translation Memory**
- **Terminology**
- **Window**
- **Help**

**File**

The options in the File menu are as follows:

<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create Project</td>
<td>create a new project.</td>
</tr>
<tr>
<td>Open Project...</td>
<td>open an existing project.</td>
</tr>
<tr>
<td>(Ctrl+Shift+P)</td>
<td></td>
</tr>
<tr>
<td>Open File (Ctrl+O)</td>
<td>open a new file.</td>
</tr>
<tr>
<td>Open in New Window</td>
<td>open a new file in a new Wordfast Pro 3 window.</td>
</tr>
<tr>
<td>Close (Ctrl+W)</td>
<td>close the currently open file. If there are unsaved changes, a warning message appears asking if you want to save the changes before closing.</td>
</tr>
<tr>
<td>Close All (Ctrl+Shift+W)</td>
<td>close all open files. If there are any unsaved changes, a warning message appears asking if you want to save the changes before closing.</td>
</tr>
<tr>
<td>Save (Ctrl+S)</td>
<td>save the currently open file.</td>
</tr>
<tr>
<td>Save Translated File (Ctrl+Alt+S)</td>
<td>save PPT, XLS or DOC files. <strong>Note:</strong> This menu option is activated only when PPT, XLS or DOC files are saved.</td>
</tr>
<tr>
<td>Save As...</td>
<td>save and rename the currently open file.</td>
</tr>
<tr>
<td>Save All (Ctrl+Shift+S)</td>
<td>save all the currently open files.</td>
</tr>
<tr>
<td>Print (Ctrl+P)</td>
<td>print the file that is currently open.</td>
</tr>
<tr>
<td>Use</td>
<td>to...</td>
</tr>
<tr>
<td>-----</td>
<td>-------</td>
</tr>
<tr>
<td>Properties</td>
<td>view information related to the currently open file, such as the original file format.</td>
</tr>
<tr>
<td>Exit (Alt+Shift+X)</td>
<td>exit Wordfast Pro 3. If there are any files open with unsaved changes, a warning message appears asking if you want to save the changes before exiting.</td>
</tr>
</tbody>
</table>

**Edit**

The options in the Edit menu are as follows:

<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo (Ctrl+Z)</td>
<td>undo most recently entered text or performed function.</td>
</tr>
<tr>
<td>Redo (Ctrl+Y)</td>
<td>redo most recently deleted text or re-perform undone function.</td>
</tr>
<tr>
<td>Cut (Ctrl+X)</td>
<td>cut the selected text. This action can be performed only in the target segment.</td>
</tr>
<tr>
<td>Copy (Ctrl+C)</td>
<td>copy the selected text.</td>
</tr>
<tr>
<td>Paste (Ctrl+V)</td>
<td>paste the copied text at the location of your cursor. This action can be performed only in the target segment.</td>
</tr>
<tr>
<td>Select All (Ctrl+A)</td>
<td>select all the text in the main Translation window.</td>
</tr>
<tr>
<td>Find/Replace (Ctrl+F)</td>
<td>search the current file for text and replace that text with another text. This action can be performed only in the target segment.</td>
</tr>
<tr>
<td>Spell Check (F7)</td>
<td>check spelling.</td>
</tr>
<tr>
<td>Preferences... (F9)</td>
<td>set translation, translation memory, penalties and terminology preferences.</td>
</tr>
<tr>
<td>Show Whitespace Characters (Ctrl+Shift+8)</td>
<td>show or hide whitespace characters.</td>
</tr>
<tr>
<td>Insert LTR Mark</td>
<td>insert Left To Right mark for languages that use left to right script.</td>
</tr>
<tr>
<td>Insert RTL Mark</td>
<td>insert Right To Left mark for languages that use right...</td>
</tr>
<tr>
<td><strong>Use</strong></td>
<td><strong>to...</strong></td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Clear Target Segment</td>
<td>clear the text in the target segment.</td>
</tr>
<tr>
<td>(Ctrl+Alt+X)</td>
<td></td>
</tr>
<tr>
<td>Clear All Target Segments</td>
<td>clear the text in all the target segments</td>
</tr>
<tr>
<td>(Alt+Shift+Delete)</td>
<td></td>
</tr>
<tr>
<td>Edit Source</td>
<td>edit the source segment.</td>
</tr>
<tr>
<td>Revert to original source</td>
<td>revert any edits made to the source segment.</td>
</tr>
<tr>
<td>Copy Source (Alt+Insert)</td>
<td>copy the source from the current segment into the target segment.</td>
</tr>
<tr>
<td>Copy All Sources (Ctrl+Alt+Insert)</td>
<td>copy all source content to the target for all segments.</td>
</tr>
<tr>
<td>Expand Segment (Alt+PageDown)</td>
<td>combine the currently selected source segment with the next segment.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This function can be accomplished only with segments in the same paragraph. Segments that have a paragraph break between them cannot be combined.</td>
</tr>
<tr>
<td>Shrink Segment (Alt+PageUp)</td>
<td>split the source segment into two segments, at the location of the cursor.</td>
</tr>
<tr>
<td>Remove All Tags</td>
<td>remove all tags in the document</td>
</tr>
<tr>
<td>Copy All Tags</td>
<td>copy all tags in the document</td>
</tr>
<tr>
<td>Remove Tags in current</td>
<td>remove tags in the current segment</td>
</tr>
<tr>
<td>segment (Ctrl+Shift+V)</td>
<td></td>
</tr>
<tr>
<td>Copy Tags in current</td>
<td>copy tags from the source to the target segment.</td>
</tr>
<tr>
<td>segment (Ctrl+Shift+A)</td>
<td></td>
</tr>
<tr>
<td>Previous Tag (Alt+Shift+Left)</td>
<td>select the previous tag in the source segment. The selected tag will be highlighted in red by default.</td>
</tr>
<tr>
<td>Copy Tag (Alt+Shift+Down)</td>
<td>copy the currently selected tag into the target</td>
</tr>
</tbody>
</table>
Use | to...
---|---
Next Tag (Alt+Shift+Right) | select the next tag in the source segment. The selected tag will be highlighted in red by default.
Edit Note... (Alt+Shift+E) | edit a note for a particular segment.
Delete Note (Alt+Shift+D) | delete a note added for a particular segment.
Add Note... (Alt+Shift+N) | add a note for a particular segment.
Last Modified Segment (Shift+F5) | navigate to the last modified segment.
Go To Segment (Ctrl+G) | navigate to a specific segment.

**Translation Memory**

The options in the Translation Memory menu are as follows:

<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>New/Select TM (Ctrl+Shift+N)</td>
<td>create or select a translation memory.</td>
</tr>
<tr>
<td>Machine Translation</td>
<td>translate a segment using machine translation software.</td>
</tr>
<tr>
<td>Retrieve Selected Tu (Alt+F12)</td>
<td>copy the TM lookup target segment into the file target segment.</td>
</tr>
<tr>
<td>Leverage Previous Tu (Alt+Left)</td>
<td>leverage the previous target segment.</td>
</tr>
<tr>
<td>Leverage Next Tu (Alt+Right)</td>
<td>leverage the next target segment.</td>
</tr>
<tr>
<td>Next Segment (Alt+Down)</td>
<td>navigate to the next segment. This action automatically saves the segment to the TM, if you have edited the translation.</td>
</tr>
<tr>
<td>Previous Segment (Alt+Up)</td>
<td>navigate to the previous segment. This action automatically saves the segment to the TM, if you have edited the translation.</td>
</tr>
</tbody>
</table>
### TXML editor menu options

<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Current Segment</strong></td>
<td>leverage the TM for the current source segment.</td>
</tr>
<tr>
<td>Leverage (Alt+ <code>-</code>)</td>
<td>translate the source segments until there is a fuzzy match.</td>
</tr>
<tr>
<td><strong>Translate Until Fuzzy</strong> (Ctrl+Alt+F)</td>
<td>translate the source segments until there is no match.</td>
</tr>
<tr>
<td><strong>Translate Until No Match</strong> (Ctrl+Shift+PageDown)</td>
<td>translate the source segments until there is no match.</td>
</tr>
<tr>
<td><strong>Translate All</strong> (Ctrl+Shift+End)</td>
<td>translate all source segments.</td>
</tr>
<tr>
<td><strong>Confirm All</strong></td>
<td>confirm all unconfirmed segments.</td>
</tr>
<tr>
<td><strong>Unconfirm All</strong></td>
<td>unconfirm all confirmed segments.</td>
</tr>
<tr>
<td><strong>Confirm/Unconfirm</strong> (Alt+Enter)</td>
<td>confirm or unconfirm a segment.</td>
</tr>
<tr>
<td><strong>Commit current segment to TM</strong> (Alt+End)</td>
<td>save the current segment to the TM.</td>
</tr>
<tr>
<td><strong>Commit all segments to TM</strong> (Ctrl+Alt+End)</td>
<td>save all the translated segments to the TM and close the file. This action is typically carried out when you have completed translation.</td>
</tr>
<tr>
<td><strong>TM Lookup</strong> (Ctrl+Shift+T)</td>
<td>look up the selected source text in the translation memory. This action leverages all segments that include that text.</td>
</tr>
<tr>
<td><strong>Analyze</strong></td>
<td>analyze the file for translation against a TM to leverage reusable content and pre-translate content.</td>
</tr>
<tr>
<td><strong>Transcheck</strong> (Ctrl+Shift+Q)</td>
<td>verify target segments and view warning messages about missing or incorrect text or variables.</td>
</tr>
</tbody>
</table>

### Terminology

The options in the Terminology menu are as follows:

<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>New/Select Glossary</strong> (Alt+N)</td>
<td>create or select a glossary.</td>
</tr>
</tbody>
</table>
Use | to...
---|---
Add Term (Ctrl+Alt+T) | add a term to the glossary.
Previous Term (Ctrl+Alt+8) | navigate to the previous term in the source segments.
Copy Term (Ctrl+Alt+0) | copy the selected term.
Next Term (Ctrl+Alt+9) | navigate to the next term in the source segments.
Run/Stop Term Highlighting (Ctrl+F5) | toggle between highlighting terms in entire TXML file or only segment in translation when Stopped (terms will still be highlighted for the currently selected segment(s)).
Edit | modify the glossary.
Import | import a glossary to the open project.
Export | export a glossary to a location, either on your computer or a common server.
Edit Blacklist | modify the blacklist.

**Window**

The options in the Window menu are as follows:

Use | to...
---|---
New Window | open a new Wordfast Pro 3 window.
Show View | preview a file in Word, HTML in a web browser, view notes and the source context. This option also allows you to add or remove the TXML Attributes, Segment Changes, TXML Context, Outline and TM Lookup tabs.
Toggle Toolbar | hide or view the toolbar.

**Help**

The options in the Help menu are as follows:

Use | to...
---|---
Online Help (F1) | view the Wordfast Pro 3 help.
Bug Report... | view or send the error log.
Check for a new | find and install new versions.
<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>version</td>
<td></td>
</tr>
<tr>
<td>Wordfast Pro 3 Dictionary Updates</td>
<td>update dictionaries that can be used during translation.</td>
</tr>
<tr>
<td>Shortcut List... (Ctrl+Shift+L)</td>
<td>view all Wordfast Pro 3 functions and keyboard shortcuts.</td>
</tr>
<tr>
<td>License Management</td>
<td>complete activation of Wordfast Pro 3 and manage license.</td>
</tr>
<tr>
<td>About Wordfast Pro 3</td>
<td>view plug-in and configuration details of Wordfast Pro 3.</td>
</tr>
</tbody>
</table>
MANAGING PROJECTS

Translation projects can be managed both by project managers and translators. Managing a project includes the following tasks:

- Creating or opening a project
- Creating or opening a translation memory
- Importing and exporting terminology lists
- Defining penalties
- Defining color codes
- Enabling spell check
- Translating in a project
- Deleting a project

Creating or opening a project

In Wordfast Pro 3, it is necessary to create a project before translating a file. You can open a TXML file for translation only if a project is created or opened. The project is a working environment that defines settings for the source and target language, translation memory, glossary, and other user information. Find below the procedures for the following tasks:

- Creating a project
- Opening a project

Creating a project

To create a project:

1. Open Wordfast Pro 3 and click .
   The TXML perspective appears.
2. Click File > Create Project.
   The Create Project dialog box appears.
3. Enter a unique **Project name**.
   **Note:** A unique project name enables differentiation. Naming the project according to the client name is a good practice. If a unique name is not given, an error message appears at the bottom of the dialog box.

4. Select **Source** and **Target Language**.
   **Note:** It is important to select the correct source and target languages. If either of them is incorrect, Wordfast Pro 3 will not allow you to open files for translation. The languages that you provide now will be the default language selection for all project files.

5. Click **OK**.
   The Open Project dialog box appears. The project name appears in the Project List and the project properties appear at the bottom of the dialog box.
6. Select project name and click **OK**.

The Preferences (Filtered) dialog box appears.
The Preferences (Filtered) dialog box is used for the following tasks:

- Selecting translation memory settings. Go to Selecting translation memory settings for more information.
- Creating or opening translation memory. Go to Creating or opening translation memory for more information.
- Importing, exporting, adding, editing, and deleting terms. Go to Importing and exporting glossaries and Working with glossaries for more information.
- Defining penalties. Go to Defining penalties for more information.
- Defining color codes. Go to Defining color codes for more information.
- Enabling spell check. Go to Enabling spell check for more information.

Opening a project

To open a project:

1. Open Wordfast Pro 3 and click .
   The TXML perspective appears.
2. Click File > Open Project.
   The Open Project dialog box appears. The project names appear in the Project list and the project properties appear at the bottom of the dialog box.
3. Select a project name and click **OK**.

The Wordfast Pro 3 screen appears with the project name on the title bar and the source and target languages at the bottom of the screen.

![Screenshot of Wordfast Pro 3 interface](image)

**Creating or opening a TM**

**CREATING OR OPENING A TRANSLATION MEMORY**

Translation memory (TM) is designed to provide maximum content re-use to and facilitate collaboration between globally distributed localization resources. Translators can leverage reusable content in two ways:

- **Local TM**: The local TM is located in your system and can only be accessed and updated by you.
- **Remote TM**: The remote TM is located on a server that can be accessed by several translators at the same time. The translators can leverage the available content and also update the TM with new reusable content.

Find below the procedures for the following tasks:

- **Selecting translation memory settings**
- **Creating a local TM**
- **Adding a local TM**
Wordfast User Guide

- Exporting a local TM
- Adding a remote TM
- Changing TM priority

Selecting translation memory settings

To select translation memory settings:

1. Open Wordfast Pro 3 and click 
   The TXML perspective appears.
2. Follow steps 1 to 6 from Creating a project.
   OR
   Click Translation Memory > New/Select TM.
   The Preferences (Filtered) dialog box appears.
3. In the left pane, click Translation Memory.
   The Translation Memory dialog box appears.

4. Select Copy source on no match in editor checkbox to copy the source to the target segment if there is no match when the TM is leveraged.
5. Enter the **Fuzzy Match Threshold in (%)**.
   **Note**: This value signifies the TM leverage percentage limit for a fuzzy match. For example, if you enter a value of 75%, the tool will mark all the translations which are leveraged below 75% match as a 'No match' segment.

6. Select **Calculate Internal fuzzy matches** checkbox, to calculate internal fuzzy matches in source files. For example, if there is a partial repetition of segments in a source file, it will be calculated as an internal fuzzy match.

7. Select the percentage that should be calculated for such segments.

8. Select **Include Internal Fuzzy matches as TM Matches** checkbox, to include internal repetitions as a TM match.

9. Select **Calculate analysis report percentage by** options: **Segment** or **Words**. The TM analysis report will display either % Segments or % Words based on this selection as shown in the screenshots below. Refer to [Analyzing files](#).

---

![Analyzing files](image)
10. Select a condition to be followed when editing an existing Translation Unit. The options are as follows:

<table>
<thead>
<tr>
<th>Select</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add to TM by overwriting the existing TU</td>
<td>overwrite the existing translation unit.</td>
</tr>
<tr>
<td>Add TM; overwrite existing TU if attributes are identical (default)</td>
<td>overwrite the existing translation unit only if custom attributes for new and existing TU are identical. This option is selected by default.</td>
</tr>
<tr>
<td>Add to TM: do not overwrite existing TU</td>
<td>add to translation memory and not overwrite existing TU</td>
</tr>
<tr>
<td>Do not add to TM</td>
<td>not update the TM.</td>
</tr>
</tbody>
</table>

11. Select checkbox to write unedited fuzzy and exact segments to a TM.

Note: This option creates a local TM that can be used on your desktop for local concordance searching. In this local TM, Machine Translated and fuzzy matches appear as 100% matches. Therefore, it is suggested that a new local TM be created for this purpose.
12. Select checkbox to perform TM lookup automatically when navigating from one segment to the other. Performing TM lookup automatically will display leveraged results.

**Warning:** Automatic TM lookup may affect system performance.

13. Select **Use Replaceables for higher TM matches** checkbox to replace the selected terms in the translation with terms from the selected TM.

**Note:** Selecting this option selects all suboptions by default. Select the checkbox to clear it, for the terms you do not want to select for replacement from the TM.

<table>
<thead>
<tr>
<th>Select</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number replacement</td>
<td>consider all numbers appearing in the source as a 100% match. All decimals and mathematical notifications are considered numbers. Alphanumeric values are not considered numbers, for example, 562HH.</td>
</tr>
<tr>
<td>URL replacement</td>
<td>consider all URLs appearing in the source as a 100% match.</td>
</tr>
<tr>
<td>Punctuation replacement</td>
<td>consider all punctuation appearing in the source as a 100% match.</td>
</tr>
<tr>
<td>Email address</td>
<td>consider all email addresses appearing in the source as a 100% match.</td>
</tr>
</tbody>
</table>

14. Click **OK**.

The translation memory properties for the project are set up.

**Creating a local TM**

To create a local TM:

1. Follow steps 1 to 2 from section **Selecting translation memory settings**.
2. In the left pane, select **Translation Memory > TM List**.
   
   The Translation Memory - TM List dialog box appears.
3. Click **Create TM**.
   The Create Local TM dialog box appears.

4. Enter or browse the location for the local TM.
5. Enter a file name for the new local TM and click **Save**.

6. Enter a **Symbolic name** for the Local TM.
   
   **Note:** Ensure that the name is unique and easily recognizable. If a unique name is not given, an error message appears at the bottom of the dialog box.

7. Select **Source** and **Target Locale**.
   
   **Note:** The default source and target languages are the same as the currently open project. Ensure that the selected TM and project have the same language pair assigned. If either of them is incorrect, the TM will not be leveraged in the project.

8. Click **OK**.

   The newly created local TM name appears in the TM List and the properties appear at the bottom of the dialog box.

9. Select the **Active** check box to use the newly created local TM during translation.

10. Select **Read-Only** check box if you do not want to update the local TM. (Optional)

11. Click **OK**.

   A new local TM is created for the project.

**Adding a local TM**

To add a local TM:
1. Follow steps 1 to 2 from section *Creating a local TM*.

2. Click **Add TM**.
The Add Local TM dialog box appears.

3. Enter or browse the location of the local TM.

4. Select a local TM file and click **Open**.
   
   **Note**: Ensure that the correct local TM is selected. The local TM file must have a correct header, which typically includes the creation date, user ID, source and target language, and so on. If an error occurs, please log in to the Wordfast Pro 3 support hotline at www.wordfast.com.

5. Follow steps 6 to 10 from section *Creating a Local TM*.
   An existing local TM is selected for the project.

**Exporting a local TM**

To export a local TM:
1. Open Wordfast Pro 3 and click 🔄. The TXML perspective appears.
2. Click Translation Memory > New/Select TM. The Preferences (Filtered) dialog box appears.
3. In the left pane, click Translation Memory > TM List.
4. Select a local TM and click Export TM. The Export Local TM dialog box appears.

![Export Local TM](image)

5. If required, select another TM from the drop down list.
6. Select the Export Type format of the TM. **Note**: You can either choose the default Wordfast Pro 3 TM format or TMX format.
7. Browse to the location where you want to save the exported TM and provide a file name.
8. Click OK. The TM is exported to the specified location in the chosen format.

**Adding a remote TM to GLTM**

To add a remote TM to GLTM:

1. Follow steps 1 to 2 from section Selecting translation memory settings.
2. In the left pane, select Translation Memory > TM List. The Translation Memory - TM List dialog box appears.
3. Click Add TM. The Add TM dialog box appears.
4. Click the WFServer tab. The WFServer options appear.
5. Enter the remote TM URL.
   The remote TM information is populated automatically when the username, password and Project Short Code are contained within the URL string. Alternatively, enter each of the remote TM properties. The remote TM URL is populated automatically.
   **Note:** The remote TM URL and login details are provided to you by the client, if they are using a Wordfast TM server.

6. After entering all remote TM information, click **Test**. Connection to the remote TM is established and a message appears.

7. Modify the **Symbolic name** for the remote TM, if required.
   **Note:** The default symbolic name is a combination of the user name, address and port details.

8. Enter **Workgroup ID** and **Search Depth**. (Optional)
   **Note:** The Workgroup ID is a 10 digit number and is provided to you by the Wordfast Pro 3 administrator. If a Workgroup ID is not entered, you can only read from the remote TM. The Workgroup ID is required if you need to update the remote TM.
Ensure that the user name is unique and easily recognizable.
Search depth signifies the number of results that can be viewed for a particular search. For example, if you are looking for segments containing the word "hotel", only the first 200 segments in the remote TM containing that word will appear.

9. Enter **Timeout Properties**.
   There are three types of timeouts:
   - Connection Timeout: controls the connection or disconnection timeout.
   - Short Timeout: controls commands that are expected to be completed immediately
   - Long Timeout: controls commands that get serialized in the server’s TM queue and possibly take a long time to complete: searches, updates, concordance searches and so on.

10. Select **Use TM Admin Password** to provide password to clean up target content and update the TM.

The example below shows the reminder that appears when the mouse is pointed to the PM and TM password properties.

![Timeout Properties](image)

**Note:** The password will be provided to you if you have Project Manager role access rights.
Find below a possible setup for a remote TM.

11. Click **OK**.

The newly created or added remote TM name appears in the TM List and the properties appear at the bottom of the dialog box. Click the TM List column name to view the list in ascending, descending or default order. If any of the TMs are selected, then the list will be sorted based on selected and unselected TMs.
Select the **Active** check box, to use the new remote TM during translation.
Select the **Read-Only** check box, if you do not want to update the remote TM. (Optional)
Click **OK**.
A new or existing remote TM is created or opened for the project.

**Changing TM Priority**

1. Click **TM Priority** under **Translation Memory**.
   
   The Translation Memory - TM Priority dialog box appears.
2. Click \( \uparrow \) or \( \downarrow \) to prioritize newly created or available local and remote TMs.

   **Note:** Prioritizing TMs will ensure that the first TM in the list is leveraged first, followed by the remaining TMs.

### Importing and exporting glossaries

A glossary is a list of source terms and their preferred translations. For example, a terminology list could include information as follows:

<table>
<thead>
<tr>
<th>Source</th>
<th>Target</th>
</tr>
</thead>
<tbody>
<tr>
<td>translation memory</td>
<td>mémoire de traduction</td>
</tr>
<tr>
<td>translation unit</td>
<td>unité de traduction</td>
</tr>
<tr>
<td>data transfer rate</td>
<td>taux de transfert de données</td>
</tr>
<tr>
<td>International Translators Federation</td>
<td>Fédération Internationale des Traducteurs</td>
</tr>
</tbody>
</table>

The glossary is stored as a tab-delimited list of source and target terms on your computer or a common server. To use a glossary, you need to import it into Wordfast Pro 3. After completing a
translation project, you also have an option to add new terms and export the glossary to your computer or a common server. Find below the procedures for the following tasks:

- Importing a glossary
- Adding a remote glossary
- Editing a remote glossary
- Exporting a glossary
- Changing Glossary Priority

**Importing a glossary**

To import a glossary:

1. Open Wordfast Pro 3 and click .
   The TXML perspective appears.
2. Click **Terminology > Import**.
   The Import Glossary dialog box appears.

3. Choose **File type**. You have two options:
   - Tab delimited text file (.txt)
   - Term Base eXchange (.tbx)
4. Enter or browse for the glossary.
5. Select checkbox to ensure that the first row of the glossary is viewed as headings.
6. Next, you have two options:
   - Select Create new Glossary if you are importing the first terminology file for the project.
   - Select Import into existing terminology, if you have already imported a glossary and want to combine both the files.
Creating a new glossary

To create a new glossary:

1. Follow steps 1 to 4 from Importing a glossary.
2. Click Create new glossary.
3. Click OK.
   The Create Glossary dialog box appears. The Symbolic Name will be populated based on the imported glossary file name. The Source and Target Language Code will be populated based on the language of the currently open project.

4. If required, enter a different Symbolic name, Source Language Code, and Target Language Code.
5. Click OK.
   The terms from the local terminology list are imported and a new terminology file is created.

Import into existing glossary

To import a new glossary into an existing glossary:

1. Follow steps 1 to 4 from Importing a glossary.
2. Select Import into existing Glossary.
   The Import into existing Glossary option is activated.
3. Select the **Existing Glossary** for the open project.

4. In the **If term already exists** prompt, select an action to perform if there is an overlap between the existing and new terminology list.

5. Click **OK**.

   The Glossary import report dialog box appears. This describes the number of terms that will be imported.

6. Click **OK**.

   The new glossary is imported and the following message will appear:

   ![Image of Glossary import dialog box]

   **Adding a remote glossary**

   A glossary can be added using the following:

   - **Term Manager**
   - **WF Server**
   - **Wordfast Anywhere**

   **Term Manager**

   To add a glossary from Term Manager:

   1. Open Wordfast Pro 3 and click **[Image]**.

      The TXML perspective appears.
2. Open the **Terminology** menu and click **New/Select Glossary**.
   The Preferences - Glossary List appears.

3. Click **Add**.
   The Add Glossary dialog box appears.
4. Give the glossary a **Symbolic Name** and assign a **Source** and **Target Language Code**.

5. Enter the **URL** of the Term Manager instance.
   The remote TMGR information is populated automatically, when the username, password and Project Short Code are contained within the URL string.
   Alternatively, enter each of the remote TM properties.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>URL</td>
<td>Enter the Term Manager URL.</td>
</tr>
<tr>
<td>Username</td>
<td>Enter the username to access Term Manager.</td>
</tr>
<tr>
<td>Password</td>
<td>Enter the corresponding password for the username.</td>
</tr>
<tr>
<td>Project Short</td>
<td>Enter the Term Manager project shortcodes. If multiple</td>
</tr>
</tbody>
</table>
Option | Description
--- | ---
Codes | Project Short Codes are needed, separate them with a comma.

6. Select the Synchronization Properties.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Synchronize blacklist terms:</td>
<td>synchronize blacklisted terms in Term Manager with TransStudio blacklist. Selected by default.</td>
</tr>
<tr>
<td>Automatic Synchronization</td>
<td>enable automatic synchronization with GlobalLink® Term Manager (TMGR) whenever a term is added or deleted. Selected by default.</td>
</tr>
<tr>
<td>Synchronize on Glossary Startup:</td>
<td>enable Term Manager synchronization when the Glossary dialog box is opened. Note: TransStudio can connect to Term Manager versions running 4.3.1 or above. Version 4.3.1 supports read access only, and read/write access is supported as of Version 4.5. Selected by default.</td>
</tr>
<tr>
<td>Synchronize interval (seconds):</td>
<td>enter the interval for Term Manager synchronization.</td>
</tr>
</tbody>
</table>

**Note:** If the remote glossary was not set up to be synchronized, it can be synchronized from the glossary. Click **Synchronize**.

When the glossary synchronization is complete, a confirmation message appears. A report appears showing the number of terms added, updated or removed.
7. Click **Test...** to test the Term Manager connection status.
   The following message appears when Wordfast successfully connects to the Term Manager instance.

8. Click **OK**.
9. Click **OK** on the Add Glossary dialog box.
   The new glossary is added to the glossary list.
**Note**: Wordfast can connect to Term Manager versions running 4.3.1 or above. Version 4.3.1 supports read access only, and read/write access is supported as of Version 4.5.

**WF Server**

To add a glossary from WF Server:

1. Open Wordfast Pro 3 and click ![image].
   The TXML perspective appears.
2. Open the **Terminology** menu and click **New/Select Glossary**.
   The Preferences - Glossary List appears.
3. Click **Add**.
   The Add Glossary dialog box appears.
4. Click the WFServer tab.
   The WFServer details appear.
5. Give the glossary a **Symbolic Name**.
6. Enter the **URL** of the WFServer to autopopulate the WF Server properties
   OR
   Enter the Address, Port, Username, and Password for the WFServer to autopopulate the URL.
7. Enter the Workgroup ID.
8. Click **Test**... to test the WFServer connection status.
   The following message appears when Wordfast successfully connects to the WFServer.

9. Click **OK** on the **Add Glossary** dialog box.
   The new glossary is added to the glossary list.
Wordfast Anywhere

To add a glossary from Wordfast Anywhere (WFA):

1. Open Wordfast Pro 3 and click  
   The TXML perspective appears.
2. Open the Terminology menu and click New/Select Glossary.
   The Preferences - Glossary List appears.
3. Click Add.
   The Add Glossary dialog box appears.
4. Click the Wordfast Anywhere tab.
   The Wordfast Anywhere details appear.

5. Give the glossary a Symbolic Name.
6. Enter the URL of Wordfast Anywhere.
7. Enter Workgroup ID.
   Note: The Workgroup ID is mandatory to connect to Wordfast Anywhere glossary. The Workgroup ID can be found in the WFA TM details.
8. Click **Test**... to test the Wordfast Anywhere connection status.
The following message appears when Wordfast successfully connects to Wordfast Anywhere.

![Test Status](image)

9. Click **OK**.
10. Click **OK** on the Add Glossary dialog box.
The new glossary is added to the glossary list.

**Error! Bookmark not defined.**

**Editing a remote glossary**

1. Open Wordfast Pro 3 and click ![icon].
The TXML perspective appears.
2. Open the Terminology menu and click **Edit**, then select the appropriate glossary.
The glossary appears.
3. Click **Search** to search through the glossary. Both Source and Target search options are available.
4. Click **Add** to add a term to the glossary.
5. Click **Synchronization** to synchronize any added terms to the glossary.

**Note:** Wordfast can connect to Term Manager versions running 4.3.1 or above. Version 4.3.1 supports read access only, and read/write access is supported as of Version 4.5.

**Exporting a glossary**

Local and remote glossaries can be exported. To export a glossary:

1. Open Wordfast Pro 3 and click ![icon].
The TXML perspective appears.
2. Click **Terminology > Export**.

OR

Select the glossary from the drop-down menu.

The glossary appears.

3. Click **Export**.

The Export Glossary dialog box appears.
4. Select **Glossary** name.
5. Select **Export type**. You have two options:
   - Tab delimited: a TXT file
   - TBX: an XML file
   Enter or browse the location for the glossary.
   Click **OK**.
   The glossary is exported and saved at the specified location.

**Changing Glossary Priority**

1. Click on **Glossary Priority** under **Terminology**.
   The Terminology - Glossary Priority dialog box appears.
2. Click \(\text{to prioritize newly created or available local and remote glossaries.}
\textbf{Note:} Prioritizing glossaries will ensure that the first glossary in the list is leveraged first, followed by the remaining glossaries.

\textbf{Defining penalties}

Penalties are defined to maintain high quality of the content leveraged from translation memory. A value is assigned to each of the penalties, which are taken into account to calculate the translation score. This score is used to differentiate between golden or 100 %, fuzzy and no match.

To define penalties:

1. Open Wordfast Pro 3 and click \(\text{The TXML perspective appears.}\)

2. Click \textbf{Edit} > \textbf{Preferences} > \textbf{Translations} > \textbf{Translation Memory} > \textbf{Penalties}.

\textbf{The Preferences (Filtered) Penalties dialog box appears.}
3. Enter values for penalties. Find below the list of penalties and description:

<table>
<thead>
<tr>
<th>Penalty</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Case</td>
<td>penalizes different case in letters.</td>
</tr>
<tr>
<td>Non literal</td>
<td>penalizes differences from source in punctuations, space, special characters like apostrophes, dashes, quotes and so on.</td>
</tr>
<tr>
<td>Tag</td>
<td>penalizes different tags.</td>
</tr>
<tr>
<td>Align</td>
<td>penalizes TUs coming from an alignment.</td>
</tr>
<tr>
<td>Penalty</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Machine translation</td>
<td>penalizes TUs coming from MT.</td>
</tr>
<tr>
<td>Multiple translations</td>
<td>penalizes TUs if there are duplicates within the TM with different translations.</td>
</tr>
<tr>
<td>Local TM</td>
<td>penalizes TU from local desktop copy.</td>
</tr>
<tr>
<td>Remote TM</td>
<td>penalizes TU from remote TM.</td>
</tr>
<tr>
<td>Private TU (Remote)</td>
<td>penalizes workgroup Translation Unit (TU) from remote TM.</td>
</tr>
<tr>
<td>Public TU (Remote)</td>
<td>penalizes non-workgroup TU from remote TM.</td>
</tr>
<tr>
<td>Attribute</td>
<td>penalizes if attributes differ.</td>
</tr>
<tr>
<td>If attribute is not:</td>
<td>consider this attribute name for penalization when the custom attribute in the TU does not match the text box attribute.</td>
</tr>
<tr>
<td>If filename attribute does not match</td>
<td>consider filename as an attribute for penalization when the filename attribute in the TU does not match the TXLF filename.</td>
</tr>
</tbody>
</table>

**Defining color codes**

The color codes are used to differentiate between different types of content in the TXML editor workspace.

To define color codes:

1. Open Wordfast Pro 3 and click ![image](image). The TXML perspective appears.
2. Click **Edit > Preferences > Translations > Colors**. The Preferences (Filtered) Colors dialog box appears. This displays the default colors assigned to different content types.
3. If you want to change the default color for any of the content types, click the colored box. For example, click the colored box next to Tag color.
A color palette appears.
4. Select a color, for example, purple and click **OK**.
   
The color code for the selected content changes from blue to purple.
Enabling spell check

Enabling the spell check option is a good practice to ensure high quality. Spell check is supported in Windows and if you have MS Office installed. Spell check is enabled by default.

To disable spell check:

1. Open Wordfast Pro 3 and click .
   The TXML perspective appears.
2. Click Edit > Preferences > Spelling.
   The Preferences (Filtered) Spelling dialog appears.
3. Select **Enable spell checking** checkbox. All spelling preferences are cleared. To select spelling preferences, select the **Enable spell checking** checkbox. The Hunspell spellcheck engine is automatically selected.

4. Select the **Check Spelling as you type** checkbox. (Optional)

5. If enabling spell checking for Portuguese, select Portuguese Modes from the drop down list. The options are:
   - Pre-Reform: traditional spellings
   - Post-Reform: new spellings
   - Both: traditional and new spellings

Select **Microsoft Office Spellcheck** to select Microsoft Office Spellcheck.
Click **OK**.
The Spell check option is enabled.

**Note**: The option for choosing spell check languages is available during installation.

To use spell check, click **Edit > Spell Check** or press **F7**.

The Spelling options appear. An example screenshot is given below.

The options available are:

<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ignore once</td>
<td>ignore the suggestions for the highlighted word or phrase.</td>
</tr>
<tr>
<td>Ignore All</td>
<td>ignore the suggestions for highlighted word or phrase in the entire file.</td>
</tr>
<tr>
<td>Add to Dictionary</td>
<td>add the word or phrase to the dictionary.</td>
</tr>
<tr>
<td>Change</td>
<td>change the existing word or phrase to the selected suggestion.</td>
</tr>
<tr>
<td>Change All</td>
<td>change all instances of the existing word or phrase to the selected suggestion.</td>
</tr>
<tr>
<td>Cancel</td>
<td>cancel spell checking.</td>
</tr>
</tbody>
</table>
Translating in a project

After you have completed the initial steps of creating project, opening translation memory, importing glossary and defining penalties and colors, the Wordfast Pro 3 workspace is ready to be used for translation. The translation process broadly includes the following tasks:

- Opening a file
- Translating a file
- Finding and replacing content
- Enabling translation options
- Enabling Machine Translation
- Enabling Auto Propagation
- Leveraging repetitive content
- Working with translation memory
- Working with glossaries
- Working with tags
- Editing source segment
- Using Transcheck
- Confirming or Unconfirming segments
- Using Outline window
- Viewing TXML Context
- Using notes
- Viewing segment changes
- Saving and closing a file
- Using shortcut icons
- Modifying colors and fonts

Opening a File

To open a file for translation:

1. Open Wordfast Pro 3 and click .
   The TXML perspective appears.
2. Click File > Open File, select file for translation and click Open.
   OR
   Left-click on the file, and drag it to the Translation window (drag_and_drop).
   The file appears in the Translation window.
**Note:** the file name appears in the tab. To view the file location (file path), point to the tab with the mouse. The file location appears in a popup.

**Note:** Wordfast Pro 3 supports only those TTX files that are translated and segmented using tag editor. The TTX files must be renamed to match the source format if they need to be viewed in tag editor.

Find below the description for the various components of the Wordfast Pro 3 workspace:

<table>
<thead>
<tr>
<th>Number</th>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
</table>
| 1      | File name | The TXML file name appears here. You can open multiple files, which appear as tabs.  
**Note:** the file name appears in the tab. To view the file location (file path), point to the tab with the mouse. The file location appears in a popup. |
| 2      | Source    | The segment that requires translation appears here. |
### Component Description

<table>
<thead>
<tr>
<th>Number</th>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>segment</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Translation score</td>
<td>The translation score, which is the percentage of match found in the TM.</td>
</tr>
<tr>
<td>4</td>
<td>Target segment</td>
<td>The translated content is entered here by the translator.</td>
</tr>
<tr>
<td>5</td>
<td>Views</td>
<td>The TXML file can be viewed in two ways, as plain text and in a table format.</td>
</tr>
<tr>
<td>6</td>
<td>TM Lookup window</td>
<td>The TM leverage results appear here. You can also search the TM for a term or a phrase. Refer to Using TM Lookup window.</td>
</tr>
<tr>
<td>7</td>
<td>Txml Context</td>
<td>The TXML context of the currently open file appears here. Refer to Viewing TXML Context.</td>
</tr>
<tr>
<td>8</td>
<td>Notes</td>
<td>The notes specific to each segment. Refer to Using notes.</td>
</tr>
<tr>
<td>9</td>
<td>Segment Changes</td>
<td>The segment changes in the currently open file appear here. Refer to Viewing segment changes.</td>
</tr>
<tr>
<td>10</td>
<td>TXML Attributes</td>
<td>The attributes of the TXML per segment appear here.</td>
</tr>
<tr>
<td>11</td>
<td>Outline window</td>
<td>The color coded list of all source segments appears here. The colors signify the translation score. Refer to Using Outline window.</td>
</tr>
</tbody>
</table>

### TRANSLATING A FILE

This section describes the steps for translating a TXML file when there are no TMs available for leverage. After entering the new translation for a file, you can save the translation to a new TM, which can be leveraged at a later stage.

To translate a file:

1. Follow the steps to open a file from section Opening a file. The file appears in the Translation window. The first translatable segment will appear in a blue background, and your cursor will be in the target segment by default. Go to Enabling translation options for information on enabling and disabling different translation options.
Note: The tags in the source segment are marked in grey. For example, {ut1}. These tags should be either copied and pasted or typed into the target segment. They should not be edited or deleted.

2. Type the target segment.
   The typed target segment will appear in a pink background as shown in the screenshot below.
Note: the source characters (SC) and the target (TC) are counted under the TM Lookup window. If a maximum character length has been set, segments exceeding the maximum show the count in red as shown in the screenshot below.

3. Select Translation Memory > Next Segment or click \ or press Alt+Down. The typed target segment is saved to the TM and the cursor moves to the next segment. Note: If you need help creating or opening a TM, go to Creating or opening a TM. To update translation memory with new content, ensure the TM has the Read only check box clear and update options are selected. Go to Selecting translation memory settings for more information. Also note that, the TM will not be leveraged or updated if you press the Enter or Tab keys or if you click into another segment in the Translation window or the Outline window.

4. After translating all the source segments, select Translation Memory > Commit all segments to TM, or click \ or press Ctrl+Alt+End, to update the TM before closing the file.

Clearing a target segment
To clear a target segment, place the cursor over the target segment, right-click and select Clear Target, or select Edit > Clear Target Segment, or press Ctrl+Alt+X.

Viewing last edited segment
You can view the last segment that was worked on by reopening the file and pressing Shift+F5. The cursor will be placed in the target segment that was last worked on.

Finding and replacing content
You can find and replace the translated content using the find and replace option.

To find and replace content:

1. Follow the steps to open a file from section Opening a file.

   The file appears in the Translation window.
2. Click **Edit > Find/Replace** or press **Ctrl+F**.
   
The Find/Replace dialog box appears.

3. Type the content in the **Find** and **Replace with** fields.
4. Enable the following options, if required:

<table>
<thead>
<tr>
<th>Select</th>
<th>to find and replace...</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Direction</strong></td>
<td></td>
</tr>
<tr>
<td>Forward</td>
<td>content after of the cursor location.</td>
</tr>
<tr>
<td>Backward</td>
<td>content before of the cursor location.</td>
</tr>
<tr>
<td><strong>Segment</strong></td>
<td></td>
</tr>
<tr>
<td>Source</td>
<td>source segments only.</td>
</tr>
<tr>
<td>Target</td>
<td>target segments only.</td>
</tr>
<tr>
<td>Source and Target</td>
<td>both source and target segments.</td>
</tr>
<tr>
<td><strong>Options</strong></td>
<td></td>
</tr>
<tr>
<td>Case sensitive</td>
<td>content with matching case.</td>
</tr>
<tr>
<td>Whole word</td>
<td>whole words only.</td>
</tr>
</tbody>
</table>
Select to find and replace...

<table>
<thead>
<tr>
<th>Select</th>
<th>to find and replace...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wrap search</td>
<td>starting from and returning to the start location.</td>
</tr>
<tr>
<td>Ignore non-breaking</td>
<td>content containing non-breaking spaces, and ignore the</td>
</tr>
<tr>
<td>space</td>
<td>non-breaking space.</td>
</tr>
</tbody>
</table>

Scope

<table>
<thead>
<tr>
<th>Scope</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>From cursor</td>
<td>from the cursor location to end of the file.</td>
</tr>
<tr>
<td>Current file</td>
<td>from the beginning to the end of the current file only.</td>
</tr>
<tr>
<td>Open files</td>
<td>in all open files.</td>
</tr>
</tbody>
</table>

5. Click **Find** to find the first instance of the content or click **Replace All** to replace all instances.

6. Click **Replace/Find** to replace the searched content and find the next instance, or click **Replace** to replace the searched content only.

OR

Drag content from source to target (drag-and-drop).

**ENABLING TRANSLATION OPTIONS**

Before or during translation, you can enable or disable some generic translation options.

To enable translations specific preferences:

1. Open Wordfast Pro 3 and click 📝.
   The TXML perspective appears.

2. Click **Edit > Preferences > Translations**.
   The Translations dialog box appears.
3. Enable the following translations options, if required:

<table>
<thead>
<tr>
<th>Select</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use &quot;smart quotes&quot;</td>
<td>enable smart quotes. Depending on the target language Wordfast Pro 3 will automatically change the quote that is used when the user presses the quote button on the keyboard.</td>
</tr>
<tr>
<td>Disable segment not committed to TM warning</td>
<td>disable the warning that appears when a translated segment is not committed to the TM before moving to the next segment.</td>
</tr>
<tr>
<td>Disable commit fuzzy segments to TM warning</td>
<td>disable the warning that appears when a fuzzy or partial match segment is committed to the TM.</td>
</tr>
<tr>
<td>Disable target overwrite warning</td>
<td>disable the warning that appears when a translated segment is overwritten.</td>
</tr>
<tr>
<td>Enable segment merging across paragraphs</td>
<td>enable segments from adjacent paragraphs to merge. A paragraph tag appears between segments merged from different paragraphs, in source and target.</td>
</tr>
</tbody>
</table>

**Enabling Machine Translation**

Wordfast Pro 3 includes an automated machine translation feature which populates translations whenever a file is open or when there are no translation memory segment matches.

To enable Machine Translation:

2. Select one of the following:

- **Always perform Machine Translation**, if you want machine translated content to appear when you leverage a segment. TM matches will appear in TM Lookup, along with the MT matches.

- **Perform when there is no TM Match**, if you want machine translated content to appear when there are no match segments.

- **Perform MT manually**, if you want machine translated content to appear only when the MT is performed manually, using the MT icon in TXML editor.

3. Select check boxes if you wish to allow all unedited segments in active document to be leveraged with MT and to remove MT score from score column when segment is edited.

4. Please read the disclaimer carefully.

5. Click **Apply**.

You can enable either **Google Translate, Microsoft Translate**, and/or **WorldLingo**.

**Google Translate**

To enable Google Translate:

1. Open Wordfast Pro 3 and click **Edit > Preferences > Translations > Machine Translation > Google Translate**.

The Google Translate Preferences dialog box appears.
2. Select **Enable Google Translator** checkbox to populate preset translations.

3. Enter the API key, which is mandatory to use Google Translate. Click the **You can also look at the video How to obtain a Google Translate API key** for more information.

4. Select **Use Google Translator as primary** checkbox to give Google MT preference over other Machine Translation service.

5. Click **Test** to test the service.

6. Click **Apply** to save the selection and **OK** if you wish to close the Preferences dialog box.

**Microsoft Translate**

To enable Microsoft Translate:

1. Open Wordfast Pro 3 and click **Edit > Preferences > Translations > Machine Translation > Microsoft Translate**.

   The Microsoft Translate Preferences dialog box appears.
2. Select **Enable Microsoft Translator** checkbox to populate preset translations.

3. Enter the **Client Id** and **Client Secret**, which are mandatory to use Microsoft Translate. Click the **Click here to obtain Microsoft Translator Client Secret** link for more information.

4. Select **Use Microsoft Translator as primary** checkbox to give Microsoft MT preference over other Machine Translation service.

5. Click **Test**, to test the service.

6. Click **Apply** to save the selection and **OK** if you wish to close the Preferences dialog box.

**WorldLingo**

To enable WorldLingo:

1. Open Wordfast Pro 3 and click **Edit > Preferences > Translations > Machine Translation > WorldLingo**.

The WorldLingo Preferences dialog box appears.
2. Select **Enable WorldLingo** checkbox, to populate preset translations.
3. Select **Use WorldLingo as primary** checkbox to give WorldLingo preference over other Machine Translation service.

**Note:** WorldLingo MT is limited to the following languages:

- English ↔ Spanish
- English ↔ German
- English ↔ Italian
- English ↔ Portuguese
- English ↔ Dutch
- English ↔ Greek
- English ↔ French
- English ↔ Swedish
- English ↔ Japanese
- English ↔ Korean
- French ↔ Spanish
- French ↔ German
- French ↔ Italian
- French ↔ Portuguese
- French ↔ Dutch
- French ↔ Greek
- English ↔ Russian
- English ↔ Arabic
- English ↔ Simplified Chinese
- English ↔ Traditional Chinese

Click Test, to test the service.

Click Apply to save the selection and OK if you wish to close the Preferences dialog box.

**Using machine translation**

To use machine translation:

1. In the TXML Editor, open a file for translation.
2. Click or press Alt++, click or press Alt+Down or click or press Alt+Up.
   The machine translation will appear in the TM Lookup window.
3. To populate the machine translation in the target segment, click or right-click in the target segment and click Machine Translation. Find below and example screenshot of a machine translated file.

![Machine Translation Screenshot](image)

**Note**: Machine translated content is highlighted in orange by default and marked as MT in the Score column. If required, the default color code can be modified. Refer to Defining color codes.
**Enabling Auto-Propagation**

You can choose to propagate translations for segments in the document automatically when you commit a segment to translation memory. The Auto-Propagation option allows you to enable or disable this feature. Enabling the Auto Propagation option will also allow you to leverage previous translation of repetitive content. For more information, refer to [Leveraging repetitive content](#).

To enable Auto-Propagation:

1. Open Wordfast Pro 3 and click ![interface_icon](image)
   The TXML perspective appears.
2. Click **Edit > Preferences > Translations > Auto-Propagation**.
   The Auto-Propagation dialog box appears.
3. Select **Enable autopropagation** checkbox to automatically propagate translation based on previous translation completed in the file.
4. Enable the following autopropagation options, if required:

<table>
<thead>
<tr>
<th>Select</th>
<th>to overwrite...</th>
</tr>
</thead>
<tbody>
<tr>
<td>100% matches</td>
<td>100% translation memory (TM) matches.</td>
</tr>
<tr>
<td>Select</td>
<td>to overwrite...</td>
</tr>
<tr>
<td>------------------------------</td>
<td>--------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Fuzzy matches</td>
<td>partial translation memory matched.</td>
</tr>
<tr>
<td>Autopropagated matches</td>
<td>all autopropagated matches. This means that if there are multiple segments that have the same content then editing one segment will auto propagate the change in all matching segments.</td>
</tr>
<tr>
<td>Modified segments</td>
<td>edited autopropagated matches. This means that if there are multiple segments that have the same content and the first and second repetitions are edited, then the following matching segments will be updated based on the second segment that was changed.</td>
</tr>
<tr>
<td>Machine Translated segments</td>
<td>machine translated content.</td>
</tr>
<tr>
<td>Committed segments</td>
<td>translated content that is committed to the TM.</td>
</tr>
</tbody>
</table>

5. Click **Apply** and **OK**. The Auto-Propagation option is enabled.

**Enabling Auto-Suggest**

The Auto-Suggest option populates suggestions based on content or numeric values from source and terminology matches.

To enable Auto-Suggest:

1. Open Wordfast Pro 3 and click ![XML](image). The TXML perspective appears.
2. Click **Edit > Preferences > Translations > Auto-Suggest**. The Auto-Suggest dialog box appears.
3. Select the **Enable Auto-Suggest** checkbox.
4. Enable the following auto-suggest options, if required:

<table>
<thead>
<tr>
<th>Select</th>
<th>to view suggestions in target segment for...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Numbers from source</td>
<td>numbers that appear in the source segment.</td>
</tr>
<tr>
<td>Number conversions</td>
<td>number conversions based on different rules. For example: If the file is being translated from English (United States) to German (Germany), $1,000 appearing in source segment will be suggested as $1.000 in the target segment.</td>
</tr>
<tr>
<td>Uppercase words from source</td>
<td>upper case words that appear in the source segment.</td>
</tr>
<tr>
<td>URLs from source</td>
<td>URLs that appear in the source segment.</td>
</tr>
<tr>
<td>Email addresses from source</td>
<td>email addresses that appear in the source segment.</td>
</tr>
<tr>
<td>Glossary matches</td>
<td>term matches from synchronized glossary found</td>
</tr>
</tbody>
</table>
Select to view suggestions in target segment for...
in the source segment.

5. Click **Apply** and **OK**.
   The Auto-Suggest option is enabled.

6. To view suggested terms, begin typing in the target segment. An example is given in the screenshot below.

![Screenshot](image.png)

**LEVERAGING REPEETITIVE CONTENT**

The leveraging repetitive content option can be used when there are repetitive segments in a file. For example, if there are multiple instances of the phrase "Our Process" then the translator needs to type the translation only once. The remaining segments are leveraged automatically. To use this feature you must enable the Auto Propagation option. For more information, refer to [Enabling Auto Propagation](#).

To leverage repetitive content:

1. Follow the steps to open a file from section **Opening a file**.
   The file appears in the Translation window. The first translatable segment will appear in a blue background, and your cursor will be in the target segment by default.
Note: There are three instances of the source segment "Auto Prop".

2. Type the target segment for the first instance.
The typed target segment will appear in a pink background as shown in the screenshot below.
3. Select **Translation Memory > Next Segment** or click 🔽 or press **Alt+Down**. 
The typed target segment is saved to the TM and the subsequent repetitive segments are 
leveraged. The segments appear in an orange background as shown in the screenshot below.
Note: The remaining two instances of "Auto Prop" are translated automatically.

**WORKING WITH TM**

Translation memory (TM) is designed to provide maximum content re-use and facilitate collaboration between globally distributed localization resources. Find below the procedures for the following tasks:

- Leveraging translation memory
- Using TM Lookup window
- Updating translation memory

**Leveraging translation memory**

To leverage translation memory:

1. Follow the steps to open a file from section *Opening a file*.
   
The file appears in the Translation window. The first translatable segment will be open, and your cursor will be in the target segment by default.
2. Select **Translation Memory > Current Segment Leverage** or click `F` or press `Alt+=`. The TM will be leveraged and the target segment appears.
USING REPLACEABLES

You can leverage the TM to replace numbers, URLs, punctuation and email addresses in the translation. If Use Replaceables for higher TM matches was selected in Preferences, the leveraged segment will overwrite the translation. For more information, go to Selecting Translation Memory Settings.

In the example below, the numbers differ in the source and target segments.

1. Select Translation Memory > Current Segment Leverage or click or press Alt++. The TM overwrites the number in the target segment.

TRANSLATION MEMORY DEFAULT COLOR REPRESENTATION

Find below the list of default color representations for source and target segments in the Translation window:

<table>
<thead>
<tr>
<th>Color</th>
<th>Representation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue</td>
<td>Source segment</td>
</tr>
<tr>
<td>Yellow</td>
<td>Fuzzy match</td>
</tr>
<tr>
<td>Grey</td>
<td>No match or NA</td>
</tr>
<tr>
<td>Green</td>
<td>100% match</td>
</tr>
<tr>
<td>Pink</td>
<td>Segment modified</td>
</tr>
</tbody>
</table>
Go to Defining color codes for more information.

Using TM Lookup window

The TM Lookup window is used to view TM leverage results and context searching. Find below the procedure for the following tasks:

- Viewing TM leverage results
- Using TM lookup

Viewing TM leverage results

The TM Lookup window displays the leverage results for the current source segment, if Perform TM Lookup Automatically is selected in Preferences. The results display the segment ID, Source and Target segments, leverage score, TM Name, User Name, and Date/Time of update to TM.

<table>
<thead>
<tr>
<th>Color</th>
<th>Representation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue</td>
<td>Source segment</td>
</tr>
</tbody>
</table>

**TM Lookup default color representation**

Find below the list of default color representations for source and target segments and translation score in the TM Lookup window:
### Color Representation

<table>
<thead>
<tr>
<th>Color</th>
<th>Representation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yellow</td>
<td>Fuzzy match</td>
</tr>
<tr>
<td>Green</td>
<td>100% match on word or phrase in target segment</td>
</tr>
<tr>
<td><strong>Highlighted text</strong></td>
<td>Words or phrases that do not match the source segment. This appears if Diff highlight is not selected.</td>
</tr>
<tr>
<td><strong>Diff Highlight Add</strong></td>
<td>Word or phrases that appear in the source but not in the TM. This appears if Diff Highlight is selected.</td>
</tr>
<tr>
<td><strong>Diff Highlight Remove</strong></td>
<td>Word or phrases that appear in the TM but not in the source. This appears if Diff Highlight is selected.</td>
</tr>
</tbody>
</table>

Go to [Defining color codes](#) for more information.

## Using TM Lookup

TM lookup is a process that searches for specific source segment text in the translation memory. The results display source and target segments.

To perform TM lookup:

1. Enter a word or phrase in the TM Lookup text box. For example,
   - Our Process: searches segments with network and systems available in lower, upper and sentence case.
   - "Our Process": searches only those segments that include both words in the same order and case.
   - Our+Process: searches segments which include both the words available in lower, upper and sentence case.

2. Select the Case sensitive check box to match case.
3. Click **Find In Source** or **Find In Target**.

   **Note:** If you want matches that only have all the words in your phrase, use + signs between each word instead of spaces. If you use spaces in the search string, then results will show
segments that have any of the words in them.

OR

1. Select a word or phrase in the source segment.
2. Press **Ctrl+Shift+T** or $\text{Ctrl+Shift+T}$. The TM Lookup results appear. The results display the segment ID, Source, and Target segments, TM Name, Username and Date/Time of update to TM.

![TM Lookup Results](image)

**Note**: The words or phrases that match the searched context are highlighted.

If no TM is selected, the following dialog box appears:

![TM Lookup Dialog](image)

3. Click **TM List** to select a TM from the list of TMs.

To continue without selecting a TM, click **OK** or close the dialog box.

**Updating translation memory**

To update translation memory with new content, ensure the TM has the **Read only** checkbox clear and update options are selected. Go to Creating or opening a translation memory and Selecting translation memory settings for more information.

When you navigate source segments by pressing **Alt+Down** or **Alt+Up** or clicking $\text{Alt+Down}$ or $\text{Alt+Up}$, segments are saved automatically to the TM.

**Note**: If you have changed the target segment, and you navigate using other methods (for example, clicking other segments to navigate directly to them), a warning message appears asking if you want to save the target segment.

**WORKING WITH TERMINOLOGY**

Find below the procedures for the following tasks:

- Setting copy term option
Managing projects

- Highlighting terms
- Auto propagating terms
- Using terminology wildcard
- Leveraging a glossary
- Adding terms
- Editing terms
- Adding blacklist
- Editing blacklist
- Wordfast Classic and Wordfast Pro glossary synchronization

Setting copy term option

The copy term option copies the source segment to the target segment.

To set copy term option:

1. Open Wordfast Pro 3 and click 📧. The TXML perspective appears.

2. Click Terminology > New/Select Glossary > Translations > Terminology. The Preferences (Filtered) Terminology dialog box appears.
3. Select one of the following copy term options:
   - Copy only source: to copy source term from the source segment to the target segment.
   - Copy only target terms: to copy target term to the target segment.
   - Copy both source and target glossary terms: to copy both source and target terms to the target segment.

4. Select **Disable automatic fuzzy term recognition** checkbox to ensure that fuzzy matches from the glossary are not leveraged.

5. Select **Highlight terms in Editor with Box** to enable highlighting of terms with a box in the TXML Editor.

6. Select **Ignore case for term highlights** to ignore case when highlighting terms.

7. Click **Apply** and **OK**.

**HIGHLIGHTING TERMS**

To highlight terms:

1. Click **Terminology > New/Select Glossary > Translations > Terminology**.
   The Preferences (Filtered) Terminology dialog box appears.
2. Select **Highlight terms in Editor with Box** checkbox to highlight terms in the TXML editor in different colors with a box as explained below.

<table>
<thead>
<tr>
<th>Color</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green</td>
<td>100% match in source and target</td>
</tr>
<tr>
<td>Orange</td>
<td>(fuzzy in source or target)</td>
</tr>
<tr>
<td>Red</td>
<td>match in source but no match in target</td>
</tr>
</tbody>
</table>

3. Click **Apply** and **OK**.

The terms are highlighted as shown in the screenshot below.

![Screenshot of TXML editor with highlighted terms]

Under the Terminology menu click **Run/Stop Term Highlighting** (Ctrl+F5) to highlight terms and to turn off highlighting for all segments. The terms will still be highlighted for the currently selected segment.

**Auto-propagating terms**

To auto-propagate terms:

1. Follow the steps to open a file from **Opening a file**.

The file appears in the Translation window. If a term from the glossary exists in the source segment, it will appear in **red** by default.
**Note:** Ensure that a glossary is imported and selected for the project. For more information, refer to [Importing a glossary](#).

2. Select **Edit > Copy Source** or click ![paste](https://example.com/paste.png) or press **Alt+Insert**, to copy the text from the source segment into the target segment.

The glossary term translation is auto propagated as shown in the screenshot below.

![Project Window](https://example.com/project_window.png)

**Note:** The term 'Process' is followed by its translation 'Proceso'.

**Using a term wildcard**

To add and use a term wildcard:

1. Follow the steps to open a file from [Opening a file](#).

The file appears in the Translation window. If a term from the glossary exists in the source segment, it will appear in red by default.

2. Click **Terminology > Edit**.

3. Select the glossary that you want to edit.

The glossary appears.

4. Double-click the entry you want to modify.

The Edit term dialog box appears.
5. Type a '*' after the term to populate all variations of the selected term. For example, the wildcard term 'Process*' will populate the target 'Proceso' for all term variations such as 'Processes', 'Processing', and so on.

6. Click Modify.
The terminology wildcard is activated.

**Leveraging a glossary**

To leverage a glossary:

1. Follow the steps to open a file from [Opening a file](#).
   The file appears in the Translation window. If a term from the glossary exists in the source segment, it will appear in red by default.

   ```
   site globalization solutions, and top three car and truck rental sys of an initiative that will provide Internet in Spanish.
   ```

2. Select **Terminology > Previous Term / Next Term** or click ➡ or ⬅ or press **Ctrl+Alt+8 / Ctrl+Alt+9**.
The term is highlighted and selected.

3. In the target segment, place the cursor at the location where you want the translated term to appear.

4. Select **Terminology > Copy Term** or click ⏎ or press **Ctrl+Alt+0**.
The translated term appears in the target segment.
Adding terms

There are two ways to add terms to a local or remote glossary:

1. Click **Terminology > Add Term** or click [ ].
   The Add to glossary dialog box appears.

![Add to Glossary dialog box]

2. Enter the term in the Source or Target field.
3. Enter a **Description** of the term if desired.
4. Select the glossary to which you want to add the term.
5. Click **OK**.

OR
1. Select text from the source or target segment. Press Ctrl+Alt+T, or click Terminology > Add Term or click .

2. The Add to Glossary dialog box appears. The selected text appears in the source or target field, depending on whether it is in the source or target segment. In the example below, the selected text appears in the source field.

3. Enter a Description of the term if desired.

4. Select the glossary to which you want to add the term.

5. Click OK.

OR

1. To continue and add text to the target field, keep the Add to Glossary dialog box open.
   Select text from the target segment. Press Ctrl+Alt+T, or click Terminology > Add Term or click . The selected text appears in the target field.
2. Enter a **Description** of the term if desired.
3. Select the glossary to which you want to add the term.
4. Click **OK**.
   The new term is added.

Alternatively,

1. Click **Terminology > Edit** or click ![button](image).
2. Select the glossary list to which you want to add terms.
   The glossary list appears.
Note: To expand or shrink a column, point to the right edge of the column's header with the mouse.

A two-directional arrow appears.

Drag the arrow to the right to shrink the column.

Drag the arrow to the left to shrink the column.

3. Click Add.

The Add term dialog box appears.

4. Enter Source, Target, and Description of the term.

Note: If you are adding a term to a remote glossary, the Description field will not be available.
5. Click **Add**.

The new term is added.

**Editing terms**

To edit terms:

1. Click **Terminology > Edit** or click ![Edit](image) or **Ctrl+Alt+Enter**.
2. Select the glossary list that you want to edit.

The glossary list appears.

![Glossary List](image)

**Note:** To expand or shrink a column, point to the right edge of the column's header with the mouse.

A two-directional arrow appears.

![Description and Creation Date](image)
Drag the arrow to the right to shrink the column.
Drag the arrow to the left to shrink the column.

3. Double-click the term you want to modify.
   OR
   Select a term and click Modify.
   OR
   Right-click a term. The terminology editor submenu appears:
   
   ![Terminology editor submenu]
   
   4. Click Modify.
   The Edit term dialog box appears.

   ![Edit term dialog box]

   5. Enter the necessary changes and click Modify.
   The modified term appears in the glossary.

*Copy a term*

1. Click Terminology > Edit or click or press Ctrl+Alt+Enter.
2. Select the glossary list that you want to edit.
   The glossary list appears.
3. Right-click a term. The terminology editor submenu appears:

![Modify term]

- Modify term
- Delete term
- Copy
- Select All

4. Click **Copy**.

   The term is copied from the Terminology Editor.

**Adding a blacklist**

A blacklist includes words or phrases that should not be used in the target segment.

To add a blacklist:

1. Click **Edit > Preferences > Terminology > Blacklist**.
   
   The Blacklist dialog box appears.

2. Click **Create**, to create a new blacklist or **Add**, to add an existing blacklist.
   
   **Note**: the blacklist must be a tab-delimited file.

3. Browse and select the location of the new blacklist or existing blacklist.

4. Type a symbolic name and select the language code of the blacklist.

5. Click **OK**.

   The newly created or selected blacklist appears in the Blacklist List.
Managing projects

6. Select **Selected** check box to use the blacklist during translation.

7. Select **Read only** check box, if you do not want to update the blacklist. (Optional)

8. Click **OK**.

   A new or existing blacklist is created or opened for the project.

*Editing blacklist*

To edit an existing blacklist:

1. Open Wordfast Pro 3 and click ✂.

   The TXML perspective appears.

2. Click the Edit blacklist icon and select the blacklist as shown in the screenshot below.

   ![Blacklist Screenshot](image)

   The Blacklist appears as a separate tab.
**Note:** To expand or shrink a column, point to the right edge of the column's header with the mouse.

A two-directional arrow appears.

Drag the arrow to the right to shrink the column.
Drag the arrow to the left to shrink the column.

3. To add a term to the blacklist, click **Add**.
The Add Term dialog box appears.

4. Enter the Forbidden and Suggested term.
5. Click **Add**.
The forbidden term and suggestion appears in the blacklist.

6. To modify a term from the blacklist, select the term and click **Modify**.
The Modify Term dialog box appears.
7. Edit the Forbidden and Suggested term and click **Modify**.
8. To delete a term from the blacklist, select the term and click **Remove**. A warning message appears.

9. Click **Yes** to delete the blacklisted term.

**Wordfast Pro and Wordfast Classic glossary synchronization**

Wordfast Professional (WF Pro) and Wordfast Classic (WFC) can synchronize their glossaries. A WF Pro glossary must be created for WFC to use it. The WF Pro glossary file is located here: C:\Users\User\wf_workspace\glossaries. Beside the Lucene glossary folder, which has been created in the past, a TXT file is created as well. WFC must connect to this TXT glossary file (gl_1). Once the WF Pro glossary is created, WF Pro must be closed in order for WFC to connect to the WF Pro glossary. Every change on the glossary file will be reflected and visible on both sides. WF Pro cannot connect to the WFC glossary file, but it can import it and WFC can reuse it by connecting to WF Pro glossary file.

The example below demonstrates glossary synchronization between WF Pro and WFC.

1. Open a word document and activate Wordfast Classic as shown in the screenshot below.
2. Click a term that you would like to add to the glossary and press Ctrl + Alt + T. The Edit entry dialog box appears.
3. Enter the source and/or target of the term and click **OK**.
The term is added to the glossary. For more information refer to the Wordfast Classic training material available here: http://www.wordfast.com/store_download.html.

4. Open Wordfast Pro and click the Edit icon and select the glossary that was updated using Wordfast Classic.
The new term will appear in the glossary as shown in the screenshot below.
**Working with Tags**

A tag is inline text that is not translatable, for example, HTML code within a sentence. Target segments should have the same tags as the source segment. However, depending on the language, sometimes a tag is not needed. If you try to save a target segment with missing tags, a warning message appears. Find below an example of a source segment with two tags:

Please contact the hotel for further information at {ut1}info@companyname.com{ut2}.

The {ut1} and {ut2} text strings represent tags.

Find below the procedures for the following tasks:

- Viewing tags
- Copying tags
- Editing tags
- Deleting tags
- Removing all tags

**Viewing tags**

To view tags:
1. Follow the steps to open a file from Opening a file.
   The file appears in the Translation window. If a tag exists in the source segment, it will appear
   in gray by default.

2. Point to the tag with the mouse.
   The actual text in the tag appears. Find below an example of the popup for the \{ut1\} tag.

3. The first tag in the source segment is highlighted in red as soon as the cursor is placed in the
   target segment.
**Copying tags**

To copy tags:

1. Follow the steps to open a file from [Opening a file](#).
   The file appears in the Translation window. If a tag exists in the source segment, it will appear in gray by default.

2. In the target segment, type the tag as it appears in the source segment, for example {ut1}.

**OR**

1. In the source segment, place the cursor before the tag and drag the mouse to select it.
2. Drag the selected tag to the target segment (drag-and-drop).

**OR**

1. In the source segment, place the cursor before the tag and drag the mouse to select it.
2. Right-click and select **Copy** or use the **Ctrl+C** shortcut key to copy the tag.
3. In the target segment, place the cursor where you want to paste the tag.
4. Right-click and select **Paste** or use the **Ctrl+V** shortcut key to paste the tag.

**OR**

1. Select **Edit > Tags > Previous Tag** / **Next Tag** or click [←] or [→] or press **Alt+Shift+Left** / **Alt+Shift+Right**.
   The tag is highlighted in red and selected. The first tag in a segment is highlighted when the segment is clicked.

   ![Example tags](image)

- If you type the same tag twice, the following error message appears.

   ![Error message](image)

- If the target segment does not contain tags, the following error message appears.
2. Place the cursor where you want the tag in the target segment.

3. Select Edit > Tags > Copy Tag or click or press Alt+Shift+Down and type the characters of the tag.
   The tag appears in the target segment.

4. To copy all tags from the source segment to the target segment, click Edit > Tags > Copy Tags in Current Segment or click or press Ctrl+Shift+A.

**Editing tags**

To edit tags:

1. Follow the steps to open a file from Opening a file.
   The file appears in the Translation window. If a tags exists in the source segment, it will appear in gray by default.

2. Place your cursor in the tag's text in the target segment, right click, and select Edit Tag.
   The Edit Tag dialog box appears.

3. Modify the tag as required and click OK.
   **Note:** The tag in the source segment should not be modified. Ensure that the modifications are valid. If not, the TXML file could get corrupted.
Deleting tags
The tag can be deleted only in the target segment. To delete tags, in the target segment place the cursor before the tag and drag the mouse to select it. Right-click and select Cut (or press the Ctrl+X shortcut key or Backspace on your keyboard).

Removing tags in current segment
Tags can be removed only in the target segment.
To remove tags from the target segment:

1. Select the segment from which you want to remove tags.
   The segment is highlighted in pink.

![Image of Wordfast interface with tags highlighted]

2. Click Edit > Tags > Remove tags in current segment.
   OR
   Press Ctrl+Shift+V.
The tags are removed from the current segment.

 Removing all tags

Tags can be removed only in the target segment.

To remove all tags in the target segment:

1. Click Edit > Tags > Remove all tags.
   
   The following dialog box appears.

2. Click Yes to confirm and remove all tags from the target segment.

Editing source segment

The Edit Source option allows you to modify the source content of the file being translated. The original source content is stored in the TXML and can be restored at any time.

To edit the source segment:

1. Follow the steps to open a file from section Opening a file.
   
   The file appears in the Translation window.
2. Select a segment and click **Edit > Edit Source** or 📊 on the dashboard. The Edit Source dialog box appears.

![Edit Source dialog box](image)

3. Edit the source content in the Modified Source box and click **OK**. The source segment is modified and a Modified Source icon 📊 appears before the segment as shown in the screenshot below.
To revert to original source, click **Edit > Revert to original source** or on the dashboard.

**USING TRANSCHECK**

The Transcheck option verifies certain elements in the target segments and warns you about missing or incorrect text or variables. For example, if you do not insert a tag or type incorrect text, a warning signal will appear before the target segment. You will be able to view the warning on mouse over.

Find below the procedures for the following tasks:

- **Enabling Transcheck**
- **Viewing Transcheck warning**

**Enabling Transcheck**

To enable Transcheck:

1. Open Wordfast Pro 3 and click .
   The TXML perspective appears.
2. Click **Edit > Preferences > Translations > Transcheck**.
   The Transcheck dialog box appears.

![Managing projects](image-url)
3. Select **Enable Transcheck** checkbox.
   The **Active Transcheck** checkbox is activated.

4. Select **Active Transcheck** checkbox, if you want Transcheck to be activated before the translation is updated to the TM.

5. To check for specific errors in the target segments, select the different **Configuration** options.
   The options available are:
### Select to check...

<table>
<thead>
<tr>
<th>Select</th>
<th>Check</th>
</tr>
</thead>
<tbody>
<tr>
<td>Partial</td>
<td>the character count between the source and target segments.</td>
</tr>
<tr>
<td>Empty target</td>
<td>for empty target segments.</td>
</tr>
<tr>
<td>Numerical Check</td>
<td>if the numerals in the source segment match the target segment. The numbers with hyphens will be read as two separate numbers.</td>
</tr>
<tr>
<td>Tag</td>
<td>for missing tags in the target segments.</td>
</tr>
<tr>
<td>Forbidden Characters</td>
<td>check if the target segment includes forbidden characters.</td>
</tr>
<tr>
<td>Punctuations</td>
<td>for consistency in punctuation between source and target segments.</td>
</tr>
<tr>
<td>Note: The punctuation transcheck only works on end of segmentation punctuation.</td>
<td></td>
</tr>
<tr>
<td>Untranslatable</td>
<td>check if the untranslatable content in source and target segments is consistent.</td>
</tr>
<tr>
<td>Copied Source Check</td>
<td>if the source segment has been copied to the target segment.</td>
</tr>
<tr>
<td>Terminology Check</td>
<td>if the terms in the source segment are translated correctly based on the glossary.</td>
</tr>
<tr>
<td>Blacklists check</td>
<td>if the target segment includes blacklisted terms. Note: The blacklisted term list must be a tab-delimited file.</td>
</tr>
<tr>
<td>First word capitalization Check</td>
<td>if the first word of each segment is capitalized.</td>
</tr>
</tbody>
</table>

6. Choose the display option from the drop down list. You can view Transcheck as an error or warning.
7. Click **OK**.
   The Transcheck option is enabled.

**Viewing Transcheck warning**

To view Transcheck warning:

1. Follow the steps to open a file from section **Opening a file**.
   The file appears in the Translation window.
2. Type the target segment.
   A warning message and a warning signal appear before the target segment as shown in the screenshot below.

![Screenshot showing warning message and warning signal](image1)

3. Point to the warning signal with the mouse.
   The text in the warning appears as shown in the screenshot below.

![Screenshot showing warning text](image2)

**Note:** The Transcheck warning appeared because the first letter in the first word of the target segment was not capitalized. The warning signal disappears when the segment is corrected as shown in the screenshot below.
CONFIRMING OR UNCONFIRMING SEGMENTS

The Confirm/Unconfirm Segment option allows the translator to mark a segment for future reference. For example, if the translator wants to check and confirm a segment after referring to some resources, he or she can mark the segment and review it at a later stage.

To confirm or unconfirm a segment:

1. Follow the steps to open a file from section Opening a file.
   
The file appears in the Translation window. The first translatable segment will appear in a blue background, and your cursor will be in the target segment by default.

2. Type or leverage the target segment from the translation memory.
   The target segment will appear.

3. Click Translation Memory > Confirm/Unconfirm or 🌟, to mark the segment.

   A 🌟 symbol appears next to the segment in the Outline window as shown in the screenshot below.
Note: The symbol will disappear only when you click Translation Memory > Confirm/Unconfirm or Alt+Enter again to confirm the segment. Unconfirmed segments are not committed to the TM when you click Translation Memory > Next Segment, or press Alt+Down, or click Translation Memory > Commit current segment to TM, or press Alt+End.

**Using Outline Window**

The Outline window is used for source segment navigation. The source for each translatable segment is listed with color-coded icons that represent the translation score. The segments that need to be confirmed are also marked by an asterisk (*) in the Outline window. Find below an example of an Outline window:
Navigating using Outline window

To view a source segment, in the Outline window, place the cursor on a source segment and left-click. The source segment is selected and highlighted.

Sorting segments

To sort the source segments, click the drop down list. The following options appear:

<table>
<thead>
<tr>
<th>Select</th>
<th>to view...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show all</td>
<td>all segments.</td>
</tr>
<tr>
<td>100% only</td>
<td>100% translation memory matches.</td>
</tr>
<tr>
<td>Fuzzy only</td>
<td>fuzzy or partial translation memory matches.</td>
</tr>
<tr>
<td>No match</td>
<td>no matches only.</td>
</tr>
<tr>
<td>Modified Segments</td>
<td>modified segments only.</td>
</tr>
<tr>
<td>All Except 100%</td>
<td>all segments except 100% translation memory matches.</td>
</tr>
<tr>
<td>With Notes</td>
<td>segments with notes. Go to Using notes for more information.</td>
</tr>
<tr>
<td>Empty target</td>
<td>segments with empty targets.</td>
</tr>
<tr>
<td>Autopropagated</td>
<td>segments that are autopropagated. Go to Enabling Auto Propagation for more information.</td>
</tr>
<tr>
<td>With transcheck errors</td>
<td>segments with transcheck errors. Go to Using Transcheck for more information.</td>
</tr>
<tr>
<td>Unconfirmed</td>
<td>segments that are unconfirmed. Go to Confirming or Unconfirming segments for more information.</td>
</tr>
<tr>
<td>With edited source</td>
<td>segments with modified source content. Go to Editing source segment for more information.</td>
</tr>
<tr>
<td>With revisions</td>
<td>revised segments. Go to Viewing segment changes for more information.</td>
</tr>
</tbody>
</table>
Outline window default color representation

Find below the list of default color representations for source and target segments in the Translation window:

<table>
<thead>
<tr>
<th>Color</th>
<th>Representation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yellow</td>
<td>Fuzzy match</td>
</tr>
<tr>
<td>Grey</td>
<td>No match or NA</td>
</tr>
<tr>
<td>Green</td>
<td>100% match</td>
</tr>
<tr>
<td>Pink</td>
<td>Segment modified since the original file was created</td>
</tr>
<tr>
<td>Purple</td>
<td>Segment modified and updated to translation memory</td>
</tr>
</tbody>
</table>

Go to Defining color codes for more information.

**VIEWING TXML CONTEXT**

The TXML Context window is used to view the TXML context of the currently open file. You also have the option to view the XML Source. Find below an example of a TXML Context window:
USING NOTES

While translating or reviewing translated content, you have the option of adding notes specific to each segment. Find below the procedures for the following tasks:

- Adding notes
- Editing notes
- Deleting notes
- Exporting Notes

Adding notes

To add a note:

1. Follow the steps to open a file from section Opening a file.
   The file appears in the Translation window. The first translatable segment will appear in a blue background, and your cursor will be in the target segment by default.
2. Place your cursor in the segment where you want to add a note.
3. Click Add under the Notes tab or select Edit > Add Note... or click .
   The Add Note dialog box appears.
4. Enter the note in the box and click OK.
The note appears in the Notes tab and an ‘i’ symbol appears next to the segment in the Outline window as shown in the screenshot below.
Editing notes
To edit notes, click **Edit** in the Notes tab, select **Edit > Edit Note...** or right-click the note in the Notes tab and select **Edit Note** or click ![Edit Note](image).

Deleting notes
To delete notes, click **Delete** in the Notes tab, select **Edit > Delete Note...** or right-click a note in the Notes tab and select **Delete Note** or click ![Delete Note](image).

Exporting notes
To export notes in Word format,

1. Click **Export Notes** in the Notes tab. The **Save As** dialog box appears:

   ![Save As Dialog](image)

   By default, notes are saved to the same folder that contains the original files.

2. Click **Save**.

   The following message appears:

   ![Exported Message](image)
The notes are formatted as a Word table, as shown in the screenshot below.

<table>
<thead>
<tr>
<th>ID</th>
<th>Source</th>
<th>Target</th>
<th>Type</th>
<th>Notes</th>
<th>Creator ID</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>INTERNET SECURITY</td>
<td>INTERNETSICHERHEIT</td>
<td>text</td>
<td>this is a note</td>
<td>cjacques</td>
<td>Mon Nov 04 11:47:3 8 MST 2013</td>
</tr>
<tr>
<td>7</td>
<td>A personal firewall is an application which controls network traffic to and from a computer, permitting or denying communications based on a security policy.</td>
<td>Eine Personal Firewall ist eine Anwendung, welche den Netzwerkverkehr und vom Computer steuert. Auf einer Sicherheitsrichtlinie basierende Kommunikation wird zugelassen und verweigert.</td>
<td>text</td>
<td>another note</td>
<td>cjacques</td>
<td>Mon Nov 04 11:53:3 0 MST 2013</td>
</tr>
</tbody>
</table>

**VIEWING SEGMENT CHANGES**

The **Segment Changes** window is used to view the segment changes in the currently open file. The recent changes will appear on top of the list. The segment changes appear only when a file is saved. Find below an example of the **Segment Changes** window:

---

**SAVING A FILE**

To save a file:
• Click File > Save or Ctrl+S, to save the currently open file.

• Click File > Save translated file or Ctrl+Alt+S, to save a translated file to its original format. Note: When an Excel file is saved, if any of the sheet names exceed 31 characters then it will be truncated to 31 characters.

The following languages require special font rules when translated. Wordfast Pro automatically changes the target font output when it identifies characters from the following languages into the listed fonts.

- Japanese: MS Gothic UI
- Chinese: SimSun for Chinese characters, Arial for Western characters
- Korean: Batang for Times New Roman, Gulim for Arial
- Arabic: Arial

• Click File > Save As, to save and rename the file.

• Click File > Save All or Ctrl+Shift+S, to save all open files.

CLOSEING A FILE

To close a file:

• Click File > Close or click , to close the currently open file.

• Click File > Close All, to close all open files.

Note: If you close a file without saving the most recent changes, a warning message appears querying if you want to save the file.

USING SHORTCUT ICONS

Wordfast Pro 3 includes a number of shortcut icons that help you quickly complete common tasks. Find below a list of all the shortcut icons available in the TXML Editor and their functionality.

<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Ctrl+O" alt="File icon" /></td>
<td>open a new file. <strong>Note:</strong> When you browse your PC, only the file types listed in your File Associations setup (<strong>Window &gt; System Options...</strong> &gt; <strong>General &gt; Editors &gt; File Associations</strong>) will appear.</td>
</tr>
<tr>
<td><img src="Ctrl+S" alt="Save icon" /></td>
<td>save the currently open file.</td>
</tr>
<tr>
<td><img src="Ctrl+P" alt="Print icon" /></td>
<td>print the file that is currently open.</td>
</tr>
<tr>
<td><img src="Ctrl+Shift+8" alt="Show/Hide whitespace" /></td>
<td>show or hide whitespace characters.</td>
</tr>
<tr>
<td><img src="" alt="Translate icon" /></td>
<td>translate a segment using machine translation software.</td>
</tr>
<tr>
<td>Key Combination</td>
<td></td>
</tr>
<tr>
<td>-----------------</td>
<td></td>
</tr>
<tr>
<td><strong>(Ctrl+Shift+N)</strong></td>
<td>create or select a translation memory (TM).</td>
</tr>
<tr>
<td><strong>(Alt+Down)</strong></td>
<td>navigate to the next segment. This action automatically saves the segment to the TM, if you have edited the translation.</td>
</tr>
<tr>
<td><strong>(Alt+Up)</strong></td>
<td>navigate to the previous segment. This action automatically saves the segment to the TM, if you have edited the translation.</td>
</tr>
<tr>
<td><strong>(Alt+-)</strong></td>
<td>leverage the TM for the current source segment.</td>
</tr>
<tr>
<td><strong>(Ctrl+Alt+F)</strong></td>
<td>translate the source segments until there is a fuzzy match.</td>
</tr>
<tr>
<td><strong>(Ctrl+Shift+PageDown)</strong></td>
<td>translate the source segments until there is no match.</td>
</tr>
<tr>
<td><strong>(Ctrl+Shift+End)</strong></td>
<td>translate all source segments.</td>
</tr>
<tr>
<td><strong>(Alt+Insert)</strong></td>
<td>copy the text from the source segment into the target segment.</td>
</tr>
<tr>
<td><strong>(Alt+PageDown)</strong></td>
<td>combine the currently selected source segment with the next segment. If segments are merged across paragraphs, a tag appears between the merged segments in the source and the target.</td>
</tr>
<tr>
<td><strong>(Alt+PageUp)</strong></td>
<td>split the source segment into two segments, at the location of the cursor.</td>
</tr>
<tr>
<td><strong>(Alt+Enter)</strong></td>
<td>mark a segment as confirmed or unconfirmed.</td>
</tr>
<tr>
<td><strong>(Alt+End)</strong></td>
<td>save the current translated segment to the TM.</td>
</tr>
<tr>
<td><strong>(Ctrl+Alt+End)</strong></td>
<td>save the translated segments to the TM and close the file. This action is typically carried out when you have completed translation.</td>
</tr>
<tr>
<td><strong>Gift+Enter</strong></td>
<td>insert left to right mark.</td>
</tr>
<tr>
<td><strong>Gift+Left</strong></td>
<td>insert right to left mark for languages that...</td>
</tr>
</tbody>
</table>
are written in that direction, such as Arabic.

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>(Ctrl+Shift+A)</td>
<td>copies all tags from the current source segment to the target segment.</td>
</tr>
<tr>
<td>(Alt+Shift+Left)</td>
<td>select the previous tag in the source segment. The selected tag will be highlighted in red by default.</td>
</tr>
<tr>
<td></td>
<td>delete the currently selected tag.</td>
</tr>
<tr>
<td>(Alt+Shift+Down)</td>
<td>copy the currently selected tag into the target segment at the location of the cursor.</td>
</tr>
<tr>
<td>(Alt+Shift+Right)</td>
<td>select the next tag in the source segment. The selected tag will be highlighted in red by default.</td>
</tr>
<tr>
<td></td>
<td>analyze the file for translation against a TM to leverage reusable content and pre-translate content.</td>
</tr>
<tr>
<td>(Ctrl+Shift+T)</td>
<td>look up the selected source text in the translation memory. This action leverages all segments that include that text.</td>
</tr>
<tr>
<td>(F7)</td>
<td>check spelling.</td>
</tr>
<tr>
<td>(Ctrl+Alt+P)</td>
<td>preview the file in MS Word.</td>
</tr>
<tr>
<td>(Ctrl+Alt+8)</td>
<td>navigate to the previous term in the source segments.</td>
</tr>
<tr>
<td>(Ctrl+Alt+0)</td>
<td>copy the selected term.</td>
</tr>
<tr>
<td>(Ctrl+Alt+9)</td>
<td>navigate to the next term in the source segments.</td>
</tr>
<tr>
<td></td>
<td>edit the blacklist for the open project.</td>
</tr>
<tr>
<td></td>
<td>modify the glossary.</td>
</tr>
<tr>
<td>(Ctrl+Alt+T)</td>
<td>add a term to the glossary.</td>
</tr>
<tr>
<td>(Alt+Shift+E)</td>
<td>edit a note.</td>
</tr>
<tr>
<td>(Alt+Shift+D)</td>
<td>delete a note.</td>
</tr>
</tbody>
</table>
MODIFYING COLORS AND FONTS

You can modify the existing colors and fonts for tool layout, TXML editor, and View and Editor folders.

To modify colors and fonts:

1. Open Wordfast Pro 3 and click add a note.
   The TXML perspective appears.
2. Click Edit > Preferences > General > Appearance > Colors and Fonts.
   The Preferences (Filtered) Colors and Fonts dialog box appears. This displays the default colors and fonts assigned to different content types.
Managing projects

3. If you want to change the default color for any of the content types, click the content type. For example, click Txml Editor Target Font and click Change. A font dialog box appears.

4. Select a color and/or font of your choice.

Deleting a project

To delete a project:

1. Open Wordfast Pro 3 and click . The TXML perspective appears.
2. Click File > Open Project. The Open Project dialog box appears.
3. Select a project name and click Delete. A confirmation message appears, asking if you want to delete the file.
4. Click Yes. The project is deleted and removed from the Project list.
WORKING WITH ADVANCED OPTIONS

The Wordfast Pro 3 advanced options are as follows:

- Selecting memory preferences
- Selecting AutoSave Preferences
- Defining segmentation settings
- Managing shortcut keys
- Managing licenses
- Updating Wordfast Pro 3 dictionaries
- Accented characters
- Font mapping

Selecting memory preferences

You can select the maximum memory that Wordfast Pro 3 will use to ensure you can open and work with large files with ease.

To select memory preferences:

1. Open Wordfast Pro 3 and click Edit > Preferences > General > Memory Preferences.
   The Memory Preferences dialog box appears.
2. Select the amount of memory Wordfast Pro 3 will use on your machine and click **OK**.

   **Note:** Maximum memory is the Java heap size. If the memory size selected here is more than the available memory, you may get a Java heap size error.

### Selecting AutoSave Preferences

You can select the default AutoSave setting. This setting saves the file to a temp folder whenever a change is made. Once the file is saved manually, the file is removed from the temp folder and saved in the user file.

If the application crashes or is closed without saving the file, the file can be located in Auto Saved files, and then saved to the path of the original file.

To select Auto Save preferences:
1. Open TransStudio and click Edit >Preferences or press F9 to go to Preferences.

2. Click General >AutoSave.
   The AutoSave Preferences dialog box appears.

3. Default time period for AutoSave is set to 10 minutes. The minimum is one minute.

4. Click the spin box to set a time greater than one minute for Autosave.

5. Click Browse to select another location for AutoSaved files.

6. Click OK.
Defining segmentation settings

The Wordfast Pro 3 workspace (.wf_workspace folder) includes a number of default properties files that are used for file segmentation. You can either use the default properties files or export and edit these files.

To define segmentation settings:

1. Open Wordfast Pro 3 and click Edit > Preferences > Translations > Segmentation Settings.
   The Segmentation Settings Preferences dialog box appears.
2. Select the preset segmentation of your choice. The options are:

- breaksegmentation.properties
- idiomsegmentation.properties
- srxsegmentation.properties
- wfsegmentation.properties

To edit any of the preset segmentations, select the properties file and click **Export**.

Open the properties file and edit as required.

**Note**: The commonly used properties file that can be modified is the wfsegmentation.properties file.

Find below some examples of segmentation settings:

<table>
<thead>
<tr>
<th>UI description</th>
<th>Options</th>
<th>Configuration setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>A number followed by an ESM ends a segment</td>
<td></td>
<td>segmenter.strategy.trados.rule1enabled=true</td>
</tr>
<tr>
<td>An ESM without a trailing space ends a segment. This should be marked true for Chinese or Japanese projects</td>
<td>True/False</td>
<td>segmenter.strategy.trados.rule2enabled=false</td>
</tr>
<tr>
<td>An ESM followed by a space followed by a lower-case letter ends a segment</td>
<td>True/False</td>
<td>segmenter.strategy.trados.rule3enabled=false</td>
</tr>
<tr>
<td>Simple Tag Handling</td>
<td>True/False</td>
<td>segmenter.text.simpletaghandling=false</td>
</tr>
<tr>
<td>UI description</td>
<td>Options</td>
<td>Configuration setting</td>
</tr>
<tr>
<td>--------------------------------------------------------------------------------</td>
<td>-----------</td>
<td>------------------------------------------------------------</td>
</tr>
<tr>
<td>Tags after the break to associate right to the next segment</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove 2 surrounding tags rule.</td>
<td>True/False</td>
<td>segmenter.simplifier.trados.strict=false</td>
</tr>
<tr>
<td>Remove trailing tags that are preceded by ESMs.</td>
<td>True/False</td>
<td>segmenter.simplifier.trados.noesp=false</td>
</tr>
<tr>
<td>End of segment punctuation for Trados sentence iterator</td>
<td></td>
<td>breakiterator.strategy.sentence.trados.esps=.,;:?!,tab</td>
</tr>
</tbody>
</table>

After editing the properties file, click **Import** to use the edited properties file.

**Managing shortcut keys**

Wordfast Pro 3 includes a number of shortcut keys that help you quickly complete common tasks. You can also modify and create new shortcut keys. Find below the procedures for the following tasks:

- Viewing shortcut keys
- Modifying shortcut key schemes
Modifying shortcut keys

Creating shortcut keys

Viewing shortcut keys

To view shortcut keys:

1. Open Wordfast Pro 3 and click .
   The TXML perspective appears.
2. Click Help > Shortcut List... or press Ctrl+Shift+L. A list of actions and shortcut keys appear.
   The default short cut keys for Windows are as follows:
<table>
<thead>
<tr>
<th>Command</th>
<th>Keyboard shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activate Editor</td>
<td>F12</td>
</tr>
<tr>
<td>Acute Accent</td>
<td>Ctrl+'</td>
</tr>
<tr>
<td>Add Note</td>
<td>Alt+Shift+N</td>
</tr>
<tr>
<td>Add Term</td>
<td>Ctrl+H+AR+T</td>
</tr>
<tr>
<td>Angstrom Accent</td>
<td>Ctrl+Shift+®</td>
</tr>
<tr>
<td>Cedille Accent</td>
<td>Ctrl+®</td>
</tr>
<tr>
<td>Circumflex Accent</td>
<td>Ctrl+Shift+^</td>
</tr>
<tr>
<td>Clear All Target Segments</td>
<td>Alt+Shift+Delete</td>
</tr>
<tr>
<td>Clear Target Segment</td>
<td>Ctrl+Alt+X</td>
</tr>
<tr>
<td>Close</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Close All</td>
<td>Ctrl+Shift+W</td>
</tr>
<tr>
<td>Commit all segments to TM</td>
<td>Ctrl+Alt+End</td>
</tr>
<tr>
<td>Commit current segment</td>
<td>Alt+End</td>
</tr>
<tr>
<td>Confirm/Unconfirm</td>
<td>Alt+Enter</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Copy All Sources</td>
<td>Ctrl+Alt+Insert</td>
</tr>
<tr>
<td>Copy Source</td>
<td>Alt+Insert</td>
</tr>
<tr>
<td>Copy Tag</td>
<td>Alt+Shift+Down</td>
</tr>
<tr>
<td>Copy Tags</td>
<td>Ctrl+Shift+®</td>
</tr>
<tr>
<td>Copy Term</td>
<td>Ctrl+Alt+D</td>
</tr>
<tr>
<td>Copy Term/Tags</td>
<td>Ctrl+Alt+Down</td>
</tr>
<tr>
<td>Copy Word</td>
<td>Ctrl+Tab</td>
</tr>
<tr>
<td>Current Segment Leverage</td>
<td>Alt+L</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete</td>
</tr>
<tr>
<td>Delete Note</td>
<td>Alt+Shift+D</td>
</tr>
<tr>
<td>Edit</td>
<td>Ctrl+Alt+Enter</td>
</tr>
<tr>
<td>Edit Note</td>
<td>Alt+Shift+E</td>
</tr>
<tr>
<td>Exit</td>
<td>Alt+Shift+X</td>
</tr>
<tr>
<td>Expand Segment</td>
<td>Alt+PageDown</td>
</tr>
<tr>
<td>Find/Replace</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>First Segment</td>
<td>Ctrl+Home</td>
</tr>
<tr>
<td>Go To Segment</td>
<td>Ctrl+G</td>
</tr>
<tr>
<td>Grave Accent</td>
<td>Ctrl+*</td>
</tr>
<tr>
<td>Insert Ellipses</td>
<td>Ctrl+Alt+.</td>
</tr>
<tr>
<td>Insert Non-Breaking Hyphen</td>
<td>Ctrl+Shift+-</td>
</tr>
<tr>
<td>Insert Non-Breaking Space</td>
<td>Ctrl+Shift+Space</td>
</tr>
<tr>
<td>Insert Optional Hyphen</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Insert Registered Trademark symbol</td>
<td>Ctrl+Alt+R</td>
</tr>
<tr>
<td>Insert em dash</td>
<td>Ctrl+Alt+Numpad_Subtract</td>
</tr>
<tr>
<td>Insert en dash</td>
<td>Ctrl+Numpad_Subtract</td>
</tr>
<tr>
<td>Last Modified Segment</td>
<td>Shift+F5</td>
</tr>
<tr>
<td>Last Segment</td>
<td>Ctrl+End</td>
</tr>
<tr>
<td>Leverage Next Tu</td>
<td>Alt+Right</td>
</tr>
<tr>
<td>Leverage Previous Tu</td>
<td>Alt+Left</td>
</tr>
<tr>
<td>Ligature / German Sharp/Double S Accent</td>
<td>Ctrl+Shift+®5</td>
</tr>
<tr>
<td>Lowercase</td>
<td>Ctrl+Shift+Y</td>
</tr>
<tr>
<td>Maximize Active View or Editor</td>
<td>Ctrl+M</td>
</tr>
<tr>
<td>New/Open TM</td>
<td>Ctrl+Shift+N</td>
</tr>
<tr>
<td>New/Select Terminology</td>
<td>Alt+N</td>
</tr>
<tr>
<td>Next Editor</td>
<td>Ctrl+F6</td>
</tr>
<tr>
<td>Next Perspective</td>
<td>Ctrl+F3</td>
</tr>
<tr>
<td>Next Segment (No Commit)</td>
<td>Ctrl+Down</td>
</tr>
<tr>
<td>Next Segment (TM Commit)</td>
<td>Alt+Down</td>
</tr>
<tr>
<td>Next Tag</td>
<td>Alt+Shift+Right</td>
</tr>
<tr>
<td>Next Term</td>
<td>Ctrl+Alt+9</td>
</tr>
<tr>
<td>Next Term/Tag</td>
<td>Ctrl+Alt+Right</td>
</tr>
<tr>
<td>Next View</td>
<td>Ctrl+F7</td>
</tr>
<tr>
<td>Online Help</td>
<td>F1</td>
</tr>
<tr>
<td>Open File</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Open Project</td>
<td>Ctrl+Shift+P</td>
</tr>
</tbody>
</table>
### Working with advanced options

<table>
<thead>
<tr>
<th>Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Preview in MS Word</td>
<td>Ctrl+Alt+F</td>
</tr>
<tr>
<td>Previous Editor</td>
<td>Ctrl+Shift+F6</td>
</tr>
<tr>
<td>Previous Perspective</td>
<td>Ctrl+Shift+F8</td>
</tr>
<tr>
<td>Previous Segment (No Commit)</td>
<td>Ctrl+Lb</td>
</tr>
<tr>
<td>Previous Segment (TM Commit)</td>
<td>Alt+Up</td>
</tr>
<tr>
<td>Previous Tag</td>
<td>Alt+Shift+Left</td>
</tr>
<tr>
<td>Previous Term</td>
<td>Ctrl+Alt+F8</td>
</tr>
<tr>
<td>Previous Term/Tag</td>
<td>Ctrl+Alt+Left</td>
</tr>
<tr>
<td>Previous View</td>
<td>Ctrl+Shift+F7</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Quick Access</td>
<td>Ctrl+3</td>
</tr>
<tr>
<td>Quick Clean</td>
<td>Ctrl+Alt+Q</td>
</tr>
<tr>
<td>Quick Switch Editor</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Remove Term/Tag</td>
<td>Ctrl+Shift+Up</td>
</tr>
<tr>
<td>Restore Segment</td>
<td>Alt+Delete</td>
</tr>
<tr>
<td>Retrieve Selected Tu</td>
<td>Alt+F12</td>
</tr>
<tr>
<td>Run Term Highlighting</td>
<td>Ctrl+F5</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl+S</td>
</tr>
<tr>
<td>Save All</td>
<td>Ctrl+Shift+S+5</td>
</tr>
<tr>
<td>Save Translated File</td>
<td>Ctrl+Alt+S+5</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Show Key Assist</td>
<td>Ctrl+Shift+L</td>
</tr>
<tr>
<td>Show View</td>
<td>Alt+Shift+Q, Q</td>
</tr>
<tr>
<td>Show View (View:)</td>
<td>Alt+Shift+Q, X</td>
</tr>
<tr>
<td>Show View (View: Outline)</td>
<td>Alt+Shift+Q, O</td>
</tr>
<tr>
<td>Show Whitespace Characters</td>
<td>Ctrl+Shift+B</td>
</tr>
<tr>
<td>Shrink Segment</td>
<td>Alt+PageUp</td>
</tr>
<tr>
<td>Slash Accent</td>
<td>Ctrl+/</td>
</tr>
<tr>
<td>Spell Check</td>
<td>F7</td>
</tr>
<tr>
<td>Switch between source and target</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>TM Lookup</td>
<td>Ctrl+Shift+T</td>
</tr>
<tr>
<td>TM Source Lookup</td>
<td>Ctrl+Shift+F</td>
</tr>
<tr>
<td>Tilde Accent</td>
<td>Ctrl+Shift+~</td>
</tr>
<tr>
<td>Transcheck</td>
<td>Ctrl+Shift+Q</td>
</tr>
<tr>
<td>Translate All</td>
<td>Ctrl+Shift+End</td>
</tr>
<tr>
<td>Translate Until Fuzzy</td>
<td>Ctrl+Alt+F</td>
</tr>
<tr>
<td>Translate Until No Match</td>
<td>Ctrl+Shift+PageDown</td>
</tr>
<tr>
<td>Turn OFF Term Highlighting</td>
<td>Ctrl+T</td>
</tr>
<tr>
<td>Unilateral Accent</td>
<td>Ctrl+Shift+:+</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
</tr>
<tr>
<td>Uppercase</td>
<td>Ctrl+Shift+U</td>
</tr>
<tr>
<td>Uppercase/Lowercase</td>
<td>Shift+F3</td>
</tr>
<tr>
<td>Upside-down exclamation point</td>
<td>Ctrl+Alt+Shift+!</td>
</tr>
<tr>
<td>Upside-down question mark</td>
<td>Ctrl+Alt+Shift+?</td>
</tr>
</tbody>
</table>

The default shortcut keys for OSX are as follows:
<table>
<thead>
<tr>
<th>Command</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activate Editor</td>
<td>Ctrl+F12</td>
</tr>
<tr>
<td>Acute Accent</td>
<td>'</td>
</tr>
<tr>
<td>Add Term</td>
<td>Ctrl+T</td>
</tr>
<tr>
<td>Angstrom Accent</td>
<td>Ctrl+@</td>
</tr>
<tr>
<td>Build All</td>
<td>B</td>
</tr>
<tr>
<td>Circumflex Accent</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Clear All Target Segments</td>
<td>Ctrl+Del</td>
</tr>
<tr>
<td>Clear Target Segment</td>
<td>Del</td>
</tr>
<tr>
<td>Close</td>
<td>W</td>
</tr>
<tr>
<td>Close All</td>
<td>Ctrl+W</td>
</tr>
<tr>
<td>Commit all segments to TM</td>
<td>Ctrl+Alt+Y</td>
</tr>
<tr>
<td>Commit current segment</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Confirm/Unconfirm</td>
<td>Ctrl+U</td>
</tr>
<tr>
<td>Content Assist</td>
<td>Space</td>
</tr>
<tr>
<td>Context Information</td>
<td>Ctrl+Space</td>
</tr>
<tr>
<td>Copy</td>
<td>C</td>
</tr>
<tr>
<td>Copy All Sources</td>
<td>Ctrl+Insert</td>
</tr>
<tr>
<td>Copy Source</td>
<td>Ctrl+Insert</td>
</tr>
<tr>
<td>Copy Tag</td>
<td>Ctrl+F</td>
</tr>
<tr>
<td>Copy Tags</td>
<td>Ctrl+A</td>
</tr>
<tr>
<td>Copy Term</td>
<td>Ctrl+D</td>
</tr>
<tr>
<td>Copy Term/Tags</td>
<td>Ctrl+D</td>
</tr>
<tr>
<td>Copy Word</td>
<td>Tab</td>
</tr>
<tr>
<td>Cut</td>
<td>X</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
</tr>
<tr>
<td>Delete Note</td>
<td>Ctrl+Alt+D</td>
</tr>
<tr>
<td>Edit</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Edit Note</td>
<td>Ctrl+E</td>
</tr>
<tr>
<td>Exit</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Expand Segment</td>
<td>Ctrl+Alt+T</td>
</tr>
<tr>
<td>Find/Replace</td>
<td>F</td>
</tr>
<tr>
<td>First Segment</td>
<td>F</td>
</tr>
<tr>
<td>Go To Segment</td>
<td>G</td>
</tr>
<tr>
<td>Grave Accent</td>
<td>'</td>
</tr>
<tr>
<td>Insert Ellipsis</td>
<td>Ctrl+.</td>
</tr>
<tr>
<td>Insert Non-Breaking Hyphen</td>
<td>Ctrl+-</td>
</tr>
<tr>
<td>Insert Non-Breaking Space</td>
<td>Ctrl+Space</td>
</tr>
<tr>
<td>Insert Optional Hyphen</td>
<td>-</td>
</tr>
<tr>
<td>Insert Registered Trademark symbol</td>
<td>Ctrl+R</td>
</tr>
<tr>
<td>Insert em dash</td>
<td>Ctrl+Dash</td>
</tr>
<tr>
<td>Insert en dash</td>
<td>Ctrl+Dash</td>
</tr>
<tr>
<td>Last Modified Segment</td>
<td>Ctrl+F5</td>
</tr>
<tr>
<td>Last Segment</td>
<td>Del</td>
</tr>
<tr>
<td>Leverage Next TU</td>
<td>Ctrl+Alt+T</td>
</tr>
<tr>
<td>Leverage Previous TU</td>
<td>Ctrl+Alt+T</td>
</tr>
<tr>
<td>Ligature / German Sharp/Double S Accent</td>
<td>Ctrl+&amp;</td>
</tr>
<tr>
<td>Lowercase</td>
<td>Ctrl+Y</td>
</tr>
<tr>
<td>Maximize Active View or Editor</td>
<td>Ctrl+M</td>
</tr>
<tr>
<td>Minimize</td>
<td>Ctrl+M</td>
</tr>
</tbody>
</table>
Working with advanced options

New
New menu
New/Open TM
New/Select Terminology
Next Editor
Next Page
Next Perspective
Next Segment (No Commit)
Next Segment (TM Commit)
Next Tag
Next Term
Next Term/Tag
Next View
Online Help
Open File
Open Project
Paste
Preferences...
Preview in MS Word
Previous Editor
Previous Page
Previous Perspective
Previous Segment (No Commit)
Previous Segment (TM Commit)
Previous Tag
Previous Term
Previous Term/Tag
Previous View
Print
Properties
Quick Access
Quick Clean
Quick Fix
Quick Switch Editor
Redo
Refresh
Remove Term/Tag
Rename
Restore Segment
Retrieve Selected TU
Run Term Highlighting
Save
Save All
Save Translated File
Select All
Show Contributing Plug-in
Show Key Assist
Show System Menu
Show View
Show View (Outline)
Show View (Problems)
Show View Menu
Show Whitespace Characters
Shrink Segment
Slash Accent
Spell Check
Switch between source and target
Switch to Editor
TM Lookup
TM Source Lookup
Title Accent
Transcheck
Translate All
Translate Until Fuzzy
Translate Until No Match
Turn OFF Term Highlighting
Umlaut Accent
Undo
Uppercase
Uppercase/Lowercase
Upside-down exclamation point
Upside-down question mark
Modifying shortcut key schemes

To view or modify shortcut key schemes:

1. Open Wordfast Pro 3 and click . The TXML perspective appears.
2. Click Edit > Preferences. The Preferences (Filtered) screen appears.
3. Click General > Shortcut Keys. The Shortcut Keys option appears.

4. Select a Scheme from the drop down list.

![Shortcut Keys Screen]

**Note:** You can change the shortcut key scheme to Emacs, SDLX, Trados, Wordfast, or Wordfast Classic. You can also create a default scheme of your own.

Modifying shortcut keys

To modify a shortcut keys:
1. Follow step 1 and 3 from Modifying shortcut key schemes. The Keys option appears.

2. Left-click and select a Command.
   - To copy the command, click Copy Command.
   - To remove the existing binding, click Unbind Command if the shortcut key is bound.
   - To restore the binding, click Restore Command.
     The shortcut key is modified.

Creating shortcut keys
To create a new shortcut key:
1. Follow step 1 and 3 from Modifying shortcut key schemes. The commands appear.

2. Left-click and select a command.
3. Enter a Description. (Optional).
4. Place the cursor in the Binding field and press a sequence of keys. A new shortcut key is created.

Managing licenses

below the procedures for the following tasks:

- Re-installing license certificate
- Verifying current license certificate
- Update notification

Re-installing license certificate

To re-install a license certificate:

1. Remove the current version of Wordfast Pro 3 from your PC by running the Uninstaller located at Start > All Programs > Wordfast > Uninstall.
   
   Note: The Uninstaller will also run automatically when you re-install Wordfast Pro 3.

2. Download the Wordfast Pro 3 installer from the webpage http://www.wordfast.com/store_download.html to your PC.

3. Run the installer. The Wordfast Pro 3 Demo Mode appears.
Note: Wordfast Pro 3 requires a Java JRE to be installed on your PC. During installation, if Java JRE does not exist, it will be installed for you. If it exists, then Wordfast Pro 3 will refer to it when running.

In the Demo Mode, you can view and test all the functions of the software. You can purchase a Wordfast Pro 3 license from the webpage http://www.wordfast.com/store_download.html. If you do not purchase a license, you are limited to storing up to 500 translation units in your translation memories.

4. Buy the Wordfast Pro 3 license from the webpage http://www.wordfast.com/store_download.html. The license file is sent to you via email.

5. Save the license file to a known location, preferably C:\Program files\Wordfast.

6. Open the Wordfast Pro 3 Demo Mode.

7. Click Help > License Management. The Activation dialog box appears.

8. Click License Manager. 

9. Select (Re-)Install a license certificate and click Next.

10. Browse and navigate to C:\Program files\Wordfast and select the license file.

11. Click Next twice and then Finish.

12. Restart Wordfast Pro 3.

Your license is active. If you have any problems with the license and require support, please log in to the Wordfast Pro 3 support hotline at www.wordfast.com.

Verifying current license certificate
To verify the current license certificate:

1. Open Wordfast Pro 3 and go to Help > License Management. The Activation dialog appears.

2. Click License Manager.

3. Select Verify the current license certificate. The license certificate appears. It includes details of the current license.

Update notification
When you open Wordfast Pro 3, you will see an update notification if there are new version updates available.

Alternatively, you can go to the Help menu and click the Check for a new version option.

Updating Wordfast Pro 3 dictionaries
The Update Wordfast Pro 3 option updates the dictionaries that can be used during translation.

To update Wordfast Pro 3 dictionaries:

2. Select the features to be installed and click **Next**.
   The license agreement appears.
3. Select "I accept the terms in the license agreements" and click **Next**.
   The list of features that will be installed appears.
4. If required, change the location where the features should be installed and click Finish. The new features are downloaded and your current installation is automatically updated.

5. Restart Wordfast Pro 3 to activate the new dictionaries.

**Accented characters and shortcuts**

The table below lists the letters with accents supported by Wordfast Pro 3.

<table>
<thead>
<tr>
<th>Accent</th>
<th>Sample</th>
<th>Shortcut</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acute</td>
<td>Ó ó</td>
<td>Ctrl+, V</td>
<td>*= apostrophe key V= any vowel</td>
</tr>
<tr>
<td>Circumflex</td>
<td>Ô ô</td>
<td>Shift+Ctrl+^, V</td>
<td></td>
</tr>
<tr>
<td>Accent</td>
<td>Sample</td>
<td>Shortcut</td>
<td>Notes</td>
</tr>
<tr>
<td>---------</td>
<td>--------</td>
<td>-------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Grave</td>
<td>Ö ò</td>
<td>Ctrl+`, V</td>
<td></td>
</tr>
<tr>
<td>Tilde</td>
<td>Ñ ñ</td>
<td>Shift+Ctrl+~, V</td>
<td>Only works with “n, N, o, O, a, A”</td>
</tr>
<tr>
<td>Umlaut</td>
<td>Ö õ</td>
<td>Shift+Ctrl+; V</td>
<td>:= colon key</td>
</tr>
</tbody>
</table>

Example 1: To type the letter ó, hold down the **Control** key, then press the apostrophe key. Release both keys and type o. The accented letter should appear.

Example 2: To type the letter Ó, hold down the **Control** key, then press the apostrophe key. Release both keys and type O. The accented letter should appear.

Example 3: To type ñ, hold down the **Shift** key, then the **Control** key, then the ~ key. Release all three keys, then type n.

The table below lists the other foreign characters supported by Wordfast Pro 3.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Name</th>
<th>Shortcut</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>i</td>
<td>Upside-down exclamation point</td>
<td>Alt+Shift+Ctrl+!</td>
<td>Either Alt key works.</td>
</tr>
<tr>
<td>¿</td>
<td>Upside-down question mark</td>
<td>Alt+Shift+Ctrl+?</td>
<td>Either Alt key works.</td>
</tr>
<tr>
<td>Ç, ç</td>
<td>French C cedille (caps/lowercase)</td>
<td>Ctrl+,,C</td>
<td>For ç, press Control, then the comma key. Release then press c.</td>
</tr>
<tr>
<td>ÕE, øe</td>
<td>OE ligature (caps/lowercase)</td>
<td>Shift+Ctrl+&amp;,o,ö</td>
<td></td>
</tr>
<tr>
<td>ß</td>
<td>German Sharp/Double S</td>
<td>Shift+Ctrl+&amp;,S</td>
<td></td>
</tr>
<tr>
<td>Ø, ø</td>
<td>Nordic O slash (caps/lowercase)</td>
<td>Ctrl+/,o,Ø</td>
<td></td>
</tr>
<tr>
<td>Å, å</td>
<td>Nordic A-ring, Angstrom sign (caps/lowercase)</td>
<td>Shift+Ctrl+@,a,Å</td>
<td>A with ring/Angstrom Sign</td>
</tr>
<tr>
<td>Æ, æ</td>
<td>Old English AE</td>
<td>Shift+Ctrl+&amp;,a</td>
<td></td>
</tr>
</tbody>
</table>
Working with advanced options

<table>
<thead>
<tr>
<th>ligature</th>
<th>Shift+Ctrl+&amp;,A</th>
</tr>
</thead>
<tbody>
<tr>
<td>(caps/lowercase)</td>
<td></td>
</tr>
<tr>
<td>Ð, ð</td>
<td>Old English eth</td>
</tr>
<tr>
<td></td>
<td>(caps/lowercase)</td>
</tr>
<tr>
<td></td>
<td>Ctrl+',d</td>
</tr>
<tr>
<td></td>
<td>Ctrl+',D</td>
</tr>
<tr>
<td></td>
<td>Icelandic/Old English eth</td>
</tr>
<tr>
<td></td>
<td>' = apostrophe key</td>
</tr>
</tbody>
</table>

Example 1: To input Spanish upside down exclamation point ¡ (Alt+Shift+Ctrl+!), hold down the **Alt** key, then the **Shift** key, then the **Control** key, then the ! key. Release all four keys, and the ¡ punctuation will appear.

Example 2: To input French oe ligature œ (Shift+Ctrl+&,o), hold down the **Shift** key, then the **Control** key, then the & key. Release all three keys and then type o to make the letter appear.

**Font mapping**

The fonts for the listed Indic, Afrikaans and CJK languages are hard-coded and cannot be changed by the user:

- Bengali: Bangla
- Malayalam: Kartika
- Telugu: Gautami
- Kannada: Tunga
- Tamil: Latha
- Afrikaans: Arial
- Afrikaans (South Africa): Arial
- Chinese: SimSun
- Chinese (Taiwan): PMingLiU
- Chinese (China): SimSun
- Thai: Tahoma
- Thai (Thailand): Tahoma
- Hebrew: Arial
- Hebrew (Israel): Arial
- Vietnamese: Arial
- Vietnamese (Vietnam): Arial
- Japanese: MS Gothic UI
- Japanese (Japan): MS Gothic UI
- Korean: Batang
Troubleshooting Errors

This section includes a list of common errors, their cause and steps that you can follow to solve them.

Problem: Error message: Invalid license certificate

Invalid license certificate:
Invalid licensing subject!

Invalid license certificate:
Input length must be multiple of 8 when decrypting with padded cipher
Cause: These error messages appear due to the following reasons:

- License certificate is not a Wordfast Pro 3 license certificate
- License certificate has an incorrect file name or user name
- License certificate is edited or some information is missing from the file
- License certificate has expired

Solution: Contact the administrator for a new license certificate. You can contact the administrator by logging into the Wordfast Pro 3 support hotline at www.wordfast.com.

Problem: Error message: TXML source files missing
Troubleshooting errors

**Cause:** The TXML file and the original file are not at the same location or do not have the same file name.

**Solution:** Ensure that the TXML files and the original files are at the same location. If not, the cleanup process cannot be completed.

---

**Problem:** Error message: Translation memory header is invalid

**Cause:** The local TM file that is being opened does not have the correct header, which typically includes the creation date, user ID, source and target language and so on.

**Solution:** Ensure that the correct local TM is opened. If the error persists, please log into the Wordfast Pro 3 support hotline at www.wordfast.com.

---

**Problem:** Error message: Terminology skipped during import
Cause: The source or target segment is missing from the glossary.

Solution: Ensure that the imported glossary contains the source and target segments of all the terms.

Problem: Error message: Unable to connect to remote TM

Cause: The URL to the remote TM server is incorrect or invalid.

Solution:

1. Go to Edit > Preferences > Translations > Translation Memory > TM List.
2. Check if the remote TM URL is correct. This is an example of a URL string:
   wf://french_user:french_password@63.246.29.190:47110
3. Check if there are trailing spaces at the end.

Problem: Error message: Current project and local TM have different source and target languages

Cause: The source and target languages associated with the currently open project does not match the local TM language pair.

Solution:

1. Go to Edit > Preferences > Translations > Translation Memory > TM List.
2. Select the local TM and click Edit TM.
3. Change the source and target languages to match the current project language pair.
Troubleshooting errors

Problem: Error message: Current project and remote TM have different source and target languages

![Remote TM](image)

**Cause:** The source and target languages associated with the currently open project does not match the remote TM language pair.

**Solution:**

1. Go to **Edit > Preferences > Translations > Translation Memory > TM List.**
2. Select the remote TM and click **Edit TM.**
3. Change the source and target languages to match the current project language pair.

Problem: Error message: Current project and file for translation have different source and target languages.

![Txml editor](image)

**Cause:** The source and target languages associated with the currently open project does not match the file language pair.

**Solution 1:** Check that you are opening the correct file. If necessary, open the file in a text editor and view/verify the source and target language specifications.

**Solution 2:** Create a new project with source and target languages matching the file for translation. Go to [Creating a project](#) for more information.
Problem: Error message: Current project and selected Glossary do not have the same source and target language code

Cause: The source and target languages associated with the currently open project does not match the glossary pair.

Solution:
1. Go to Edit > Preferences > Translations > Terminology > Glossary List.
2. Select the glossary and click Edit.
3. Change the source and target languages to match the current project language pair.

Problem: Translation Memory is not leveraged during translation

Cause: A local or remote TM is not selected.

Solution: Ensure that you are connected to a TM. To confirm go to Translation Memory > New/Select TM > Local or Remote and check the Selected check box next to the TM you wish to use. If you have Read only selected, you will not be able to leverage or copy into the TM.

Problem: Shortcut keys not working for key strokes

Cause: The correct scheme is not selected or the shortcut key is not configured.

Solution:
1. Go to Edit > Preferences > General > Shortcut Keys > Scheme.
2. Choose the correct scheme: Wordfast Pro 3, Emacs, SDLX, Trados, Wordfast or Wordfast Classic.
3. Check the shortcut key list to ensure that all shortcut keys are configured correctly. If not, edit accordingly. Go to Managing shortcut keys for more information on viewing, modifying and creating shortcut keys.
4. Click Apply and OK.
WORKING WITH WORDFAST ALIGNER

Working with Wordfast Aligner

Wordfast Aligner is an add-on tool that converts existing translated documents into a format that is compatible with the Wordfast TM. This enables reuse of content translated using other translation tools and available in different formats. Wordfast Aligner is supported by all operating systems. This section includes the following:

- Using Wordfast Aligner
- Basic menu options
- Using shortcut icons

Using Wordfast Aligner

In Wordfast Aligner a project file (.glp) must be created for each source and target pair. A .glp includes the source and target documents that need alignment. Alignment is a process by which the source document segments are matched with the target document segments correctly. Once aligned, the documents can be exported to create a Wordfast compatible TM.

Wordfast Aligner supports TXML, DOC, PPT and XLS file formats.

To align source and target files and create a Wordfast TM using Wordfast Aligner:

1. Open Wordfast Aligner and click **File > New Project** or 
   or Ctrl+N. The New Project dialog box appears.
2. Complete the following entries:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Name</td>
<td>Enter a unique project name.</td>
</tr>
<tr>
<td>Project Location</td>
<td>Enter the path or click ![ellipsis] to select a location for the project.</td>
</tr>
</tbody>
</table>
| Source Path       | Enter the path or click ![ellipsis] to select the location of the source files.  
                     **Note:** The source files can be in TXML, DOC, PPT and XLS file formats. |
| Source Language   | Select the source language of the source documents from the drop down list. |
| Target Path       | Enter the path or click ![ellipsis] to select the location of               |

227
the target files.

**Note:** The target files can be in TXML, DOC, PPT and XLS file formats.

| Target Language | Select the target language of the target documents from the drop down list. |

3. Click **Next**.

The File Alignment page dialog box appears.

4. Review the aligned source and target files and update the JDiagram links, if required.

**Note:** You can select the link and press the **Delete** button to delete them or drag the cursor to create new links.

5. Click **Finish**.

A new project file (.glp) is created and the first document (.gld) in the project appears in the Project Aligner window as shown in the screenshot below.
Note: The file alignment is a back-end process that creates automated system links (JDiagram links) between source and target segments of a document.

6. Review the aligned source and target segments and update the JDiagram links, if required. 
   Note: You can select the link and press the Delete button to delete them or drag the cursor to create new manual links.

7. Click on the Project Explorer button to review all the documents. 
   Note: In the Project Explorer you can right click on a document name to complete the following actions: delete, mark as complete or pending. An example screenshot is shown below.

8. After reviewing all documents click Tools > Export TM or , to create a Wordfast Pro 3 compatible TM.  
   The Export TM dialog box appears.
9. Select the **Export Type** from the drop down list. The options are:

- All documents: includes open, pending and completed documents
- Current document: includes currently open document only
- Completed documents: includes documents that are marked as complete

Enter the **TM Name** and **TM Location**.

**Note**: These options are automatically populated based on the project file name.

Enter the **TM User**.

**Note**: The TM User is a penalty string that is added to the TM. This will help the user identify aligned source and target content.

Click **Finish**.

A Wordfast TM is created at the specified location.

---

**Basic Aligner menu options**

The Wordfast Aligner basic menu options are as follows:

<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong></td>
<td></td>
</tr>
<tr>
<td>New Project (Ctrl+N)</td>
<td>create a new project.</td>
</tr>
<tr>
<td>Open Project (Ctrl+O)</td>
<td>open an existing project.</td>
</tr>
</tbody>
</table>
## Working with Wordfast Aligner

### Use

<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Document (Ctrl+D)</td>
<td>open a document.</td>
</tr>
<tr>
<td>Save Document (Ctrl+S)</td>
<td>save the currently open document.</td>
</tr>
<tr>
<td>Close</td>
<td>close currently open project or document.</td>
</tr>
<tr>
<td>Exit</td>
<td>exit from the tool.</td>
</tr>
</tbody>
</table>

### Align

<table>
<thead>
<tr>
<th>Align</th>
<th>description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align All</td>
<td>align all segments in the document.</td>
</tr>
<tr>
<td>Align Down</td>
<td>align all segments below the cursor position.</td>
</tr>
<tr>
<td>Align Up</td>
<td>align all segments above the cursor position.</td>
</tr>
<tr>
<td>Reset Alignment</td>
<td>remove existing alignment.</td>
</tr>
<tr>
<td>Reset Manual Links</td>
<td>remove existing manual alignment.</td>
</tr>
<tr>
<td>Reset System Links</td>
<td>remove existing system generated alignment.</td>
</tr>
<tr>
<td>Reset Alignment Up</td>
<td>remove all alignment above the cursor position.</td>
</tr>
<tr>
<td>Reset Alignment Down</td>
<td>remove all alignment below the cursor position.</td>
</tr>
</tbody>
</table>

### View

<table>
<thead>
<tr>
<th>View</th>
<th>description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Increase Font</td>
<td>increase the font size.</td>
</tr>
<tr>
<td>Decrease Font</td>
<td>decrease the font size.</td>
</tr>
<tr>
<td>Previous Document</td>
<td>navigate to the previous document.</td>
</tr>
<tr>
<td>Next Document</td>
<td>navigate to the next document.</td>
</tr>
<tr>
<td>Project Explorer</td>
<td>View or hide the Project Explorer tab.</td>
</tr>
</tbody>
</table>

### Tools

<table>
<thead>
<tr>
<th>Tools</th>
<th>description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disable Sync Scroll</td>
<td>enable or disable sync control. This option highlights the source and the</td>
</tr>
</tbody>
</table>
### Use to...

<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export TM</td>
<td>export the aligned documents to create a Wordfast TM.</td>
</tr>
<tr>
<td>Options (Ctrl+Alt+L)</td>
<td>edit manual and system JDiagram link color, choose TM Export Format and edit fonts based on locales.</td>
</tr>
</tbody>
</table>

### Help

<table>
<thead>
<tr>
<th>Online Help</th>
<th>view the online help.</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Wordfast Aligner</td>
<td>view build and version details for Wordfast Aligner.</td>
</tr>
</tbody>
</table>

## Using Alignershortcut icons

Wordfast Aligner includes a number of shortcut icons that help you quickly complete common tasks. Find below a list of all the shortcut icons available in Wordfast Aligner and their functionality.

<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>🕳️(Ctrl+N)</td>
<td>create a new project.</td>
</tr>
<tr>
<td>📜(Ctrl+O)</td>
<td>open an existing project.</td>
</tr>
<tr>
<td>📝(Ctrl+D)</td>
<td>open a document.</td>
</tr>
<tr>
<td>📝(Ctrl+S)</td>
<td>save the currently open document.</td>
</tr>
<tr>
<td>🔖</td>
<td>align all segments in the document.</td>
</tr>
<tr>
<td>🔗</td>
<td>align all segments above the cursor position.</td>
</tr>
<tr>
<td>🔗</td>
<td>align all segments below the cursor position.</td>
</tr>
<tr>
<td>🗑</td>
<td>remove existing alignment.</td>
</tr>
<tr>
<td>🗑</td>
<td>remove existing manual alignment.</td>
</tr>
<tr>
<td>🗑</td>
<td>remove existing system generated alignment.</td>
</tr>
<tr>
<td>🗑</td>
<td>remove all alignment above the cursor position.</td>
</tr>
<tr>
<td>🗑</td>
<td>remove all alignment below the cursor position.</td>
</tr>
<tr>
<td>🗑</td>
<td>remove selected alignment link.</td>
</tr>
<tr>
<td>🟠</td>
<td>enable or disable sync control. This option highlights the source and the corresponding target segment(s).</td>
</tr>
<tr>
<td>Use</td>
<td>to...</td>
</tr>
<tr>
<td>-----</td>
<td>-------</td>
</tr>
<tr>
<td>![icon]</td>
<td>export the aligned documents to create a Wordfast TM.</td>
</tr>
<tr>
<td>![icon]</td>
<td>refresh the project aligner. This option saves changes and reloads the open projects.</td>
</tr>
<tr>
<td>![icon]</td>
<td>increase the font size.</td>
</tr>
<tr>
<td>![icon]</td>
<td>decrease the font size.</td>
</tr>
<tr>
<td>←</td>
<td>navigate to the previous document.</td>
</tr>
<tr>
<td>→</td>
<td>navigate to the next document.</td>
</tr>
</tbody>
</table>
Translation Memory Administration perspective provides a simple and user friendly interface to edit and update translation memories. This section includes the following:

- Using TM Administration perspective
- Basic menu options
- Using shortcut icons

Using TM Administration perspective

Using TM Administration perspective, users can view, edit and update both local and remote translation memories. Find below the procedures for the following tasks:

- Updating TM Administration preferences
- Modifying TM content
- Finding and Replacing Translation Units (TUs)
- Merging translation memories (TMs)
- Deleting Translation Units (TUs)
- Marking Translation Units (TUs)

Updating TM Administration preferences

To update TM Administration preferences:

1. Open Wordfast Pro 3 and click .
   The TM Administration perspective appears.

2. Click Edit > Preferences.
   The TM Administration dialog box appears.
3. Update the preferences as required. The TM Administration preferences are:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connect first TM automatically at startup</td>
<td>Select checkbox to view the TM content for the first TM in the TM Servers list.</td>
</tr>
<tr>
<td>Maximum segments that can be retrieved at a time</td>
<td>Enter the number of segments that you wish to view at a time.</td>
</tr>
<tr>
<td>Changed target color</td>
<td>Click on the color box and choose a color to represent edited TM content.</td>
</tr>
<tr>
<td>Ut tag color</td>
<td>Click on the color box and choose a color to represent tags.</td>
</tr>
<tr>
<td>Keyword match highlight color</td>
<td>Click on the color box and choose a color to represent keyword search match.</td>
</tr>
</tbody>
</table>

**Modifying TM content**

To modify TM content:
1. Double-click a TM server on the left pane or select a TM and click . The TM content appears in the right pane.

2. Select or double-click the segment that you wish to modify. The segment is selected and highlighted in pink. You can change the color by updating the TM Administration preferences.

3. Type the new translation and click . If the remote TM does not include an administrative password, the following dialog box appears.

4. Click OK or close the dialog box. The remote TM connection is initiated.
Adding an administrative password

When updating a remote TM, you must ensure the Administrative Password is entered in the Add TM or Edit TM dialog box.

To add an administrative password:

1. Go to the Edit menu and click Preferences or press F9.
   The Preferences (Filtered) dialog box appears.
2. Go to Translations > Translation Memory > TM List.
3. Click Add TM to add a new remote TM and enter the Administrative Password.
   OR
   Select an existing remote TM and click Edit TM to enter the Password.

An example screenshot is given below.
Finding and Replacing Translation Units (TUs)

You can find and replace TUs within a TM using the find and replace option.

To find and replace TUs:

1. Double-click a TM server on the left pane
   OR
   Select a TM and click .
   The TM content appears in the right pane.

2. Click TM Content > Find/Replace or press Ctrl+F.
   The Find/Replace dialog box appears.
3. Type the content in the **Find** and **Replace with** fields.

4. Enable the following options, if required:

<table>
<thead>
<tr>
<th>Select</th>
<th>to find and replace...</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Direction</strong></td>
<td></td>
</tr>
<tr>
<td>Forward</td>
<td>content after of the cursor location.</td>
</tr>
<tr>
<td>Backward</td>
<td>content before of the cursor location.</td>
</tr>
<tr>
<td><strong>Segment</strong></td>
<td></td>
</tr>
<tr>
<td>Source</td>
<td>source segments only.</td>
</tr>
<tr>
<td>Target</td>
<td>target segments only.</td>
</tr>
<tr>
<td>Source and Target</td>
<td>both source and target segments.</td>
</tr>
<tr>
<td><strong>Options</strong></td>
<td></td>
</tr>
<tr>
<td>Case sensitive</td>
<td>content with matching case.</td>
</tr>
<tr>
<td>Whole word</td>
<td>whole words only.</td>
</tr>
<tr>
<td>Wrap search</td>
<td>starting from and returning to the start location.</td>
</tr>
</tbody>
</table>

5. Click **Find** to find the first instance of the content or click **Replace All** to replace all instances.

6. Click **Replace/Find** to replace the searched content and find the next instance or click **Replace** to replace the searched content only.
Merging local translation memories (TMs)

To merge local TMs:

1. Double-click a TM server in the left pane.
   OR
   Select a TM and click .

2. Click TM Content > Merge TM or .
   The Select TM to merge dialog box appears.

3. Select the local TM to merge and click Open.
   The Merge TM options appear.

4. Select one of the Merge TM options and click OK.
   The two local TMs are merged and the following confirmation message appears.

   ![Merge options](image)

   ![Confirmation message](image)

**Note:** Ensure that the source and target language codes of the both the local TMs to be merged match. If not the following error message appears.

   ![Error message](image)
Deleting Translation Units (TUs)

To delete TUs:

1. Select the checkbox to select TUs as shown in the screenshot below.

2. Click TM Content > Delete or click ✗ or press Alt+D on the keyboard. The selected TUs are deleted.

3. Click TM Content > Update All or click 🔄 or press Ctrl+Alt+End to update the TM. To update the selected segment to the TM, click TM Content > Update Selected or click 🔄 or press Ctrl+Alt+PageDown.

4. Click TM Content > Discard All or click 🔄 or press Ctrl+Alt+Home to discard all segment changes. To discard the selected segment changes, click TM Content > Discard Selected or click 🔄 or press Ctrl+Alt+PageUp.

Marking Translation Units (TUs)

You can select TUs based on different criteria to edit them.

To mark TUs:

1. Double-click a TM server on the left pane or select a TM and click 📞.

2. Click TM Content > Mark and choose one of the options or click the Mark TUs icon 🔄 as shown in the screenshot below.
3. Select one of the options.
   A confirmation message appears.
   The Mark Same Source TUs option results in the following message:

   ![Confirmation dialog](image1)

   The Mark TUs containing tags option results in the following message:

   ![Confirmation dialog](image2)

4. Click **Yes**, to sort the marked TUs and display it on top of the TM Content panel.
   **Note**: The first TU in the group of redundant TUs will not be checked. The remaining redundant TUs are checked, allowing for easy viewing and deleting of TUs.
Removing all tags from selected Translation Units (TUs)

1. Select the TU(s) from which you want to remove tags.

2. Click TM Content> Remove All Tags.

Or

Click on the TM Admin toolbar.

The tags are removed from the selected segment(s).

To remove tags from all segments, select all segments.

Searching TUs

To search for a term or word within a TU:

1. Click the Search drop-down menu to select Source, Target, or Source and Target.

2. Enter the term to be searched in the search box.

3. Check Case □ a A to specify if the term is case-sensitive.

4. Check Exact □ Exact to restrict the search to exact matches.

5. Enter Creator to search by creator of the term.

6. Click Attribute to search by attribute added to the TXML file.

7. Specify the From and To dates for terms that were modified w/in a certain time period.
8. Click Search.

An example of a completed search is provided below.

### Basic menu options

The Wordfast Pro 3 Translation Memory Administration perspective basic menu options are as follows:

<table>
<thead>
<tr>
<th><strong>Use</strong></th>
<th><strong>to...</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong></td>
<td></td>
</tr>
<tr>
<td>Exit</td>
<td>exit from the tool.</td>
</tr>
<tr>
<td><strong>Edit</strong></td>
<td></td>
</tr>
<tr>
<td>Preferences...</td>
<td>set general, spelling, translation, translation memory, penalties and terminology preferences.</td>
</tr>
<tr>
<td><strong>TM Server</strong></td>
<td></td>
</tr>
<tr>
<td>Connect</td>
<td>connect to a Translation Memory (TM) server.</td>
</tr>
<tr>
<td>Disconnect</td>
<td>disconnect from a TM server.</td>
</tr>
<tr>
<td>Change Languages</td>
<td>create a new local TM with different languages.</td>
</tr>
<tr>
<td>Invert Languages</td>
<td>create a new local TM with the current TM languages inverted. For example, if the source and target language codes for the current TM is en-US and de-DE, then the source and target language codes for the new TM will be switched to de-DE and en-US.</td>
</tr>
<tr>
<td>Reversed Sort Order</td>
<td>reverse the TM Servers order in the left pane.</td>
</tr>
<tr>
<td>Sort By</td>
<td>sort TM Servers based on different criteria.</td>
</tr>
<tr>
<td><strong>TM Content</strong></td>
<td></td>
</tr>
<tr>
<td>Previous Tag</td>
<td>select the previous tag in the source or target</td>
</tr>
<tr>
<td>Use</td>
<td>to...</td>
</tr>
<tr>
<td>----------------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>(Alt+Shift+Left)</td>
<td>segment. The selected tag will be highlighted in red by default.</td>
</tr>
<tr>
<td>Remove Tag</td>
<td>delete the currently selected tag in the source or target segment or press Backspace on the keyboard.</td>
</tr>
<tr>
<td>Copy Tag</td>
<td>copy the currently selected tag into the source or target segment at the location of the cursor.</td>
</tr>
<tr>
<td>Next Tag (Alt+Shift+Right)</td>
<td>select the next tag in the source or target segment. The selected tag will be highlighted in red by default.</td>
</tr>
<tr>
<td>Remove All Tags.</td>
<td>remove all tags in the source or target.</td>
</tr>
<tr>
<td>Find/Replace (Ctrl+F)</td>
<td>find a replace source and/or target content.</td>
</tr>
<tr>
<td>Mark</td>
<td>• Mark Same Source Translation Units (TUs)</td>
</tr>
<tr>
<td></td>
<td>• Mark Same Source &amp; Target TUs</td>
</tr>
<tr>
<td></td>
<td>• Mark Same Source &amp; Attribute TUs</td>
</tr>
<tr>
<td></td>
<td>• Mark Same Source, Target &amp; Attribute TUs</td>
</tr>
<tr>
<td></td>
<td>• Mark TUs containing tags</td>
</tr>
<tr>
<td>Delete (Alt+D)</td>
<td>delete selected TUs.</td>
</tr>
<tr>
<td>Merge TM</td>
<td>merge two local TMs.</td>
</tr>
<tr>
<td>Remove all Deprecated TUs</td>
<td>Remove all tags beginning with xx (deprecated) in the TXML file.</td>
</tr>
<tr>
<td>Discard All (Ctrl+Alt+Home)</td>
<td>undo all segment changes.</td>
</tr>
<tr>
<td>Discard Selected</td>
<td>undo selected segment changes.</td>
</tr>
<tr>
<td>(Ctrl+Alt+PageUp)</td>
<td></td>
</tr>
<tr>
<td>Update Selected</td>
<td>update selected segment changes to the TM.</td>
</tr>
<tr>
<td>(Ctrl+Alt+PageDown)</td>
<td></td>
</tr>
<tr>
<td>Update All (Ctrl+Alt+End)</td>
<td>update all segment changes to the TM.</td>
</tr>
<tr>
<td>Window</td>
<td></td>
</tr>
<tr>
<td>New Window</td>
<td>open a new Wordfast Pro 3 window.</td>
</tr>
<tr>
<td>System Options</td>
<td>view and change the system preferences.</td>
</tr>
<tr>
<td>Toggle Toolbar</td>
<td>hide or view the toolbar.</td>
</tr>
</tbody>
</table>
## Using shortcut icons

Wordfast Pro 3 TM Administration perspective includes a number of shortcut icons that help you quickly complete common tasks. Find below a list of all the shortcut icons available in Wordfast Pro 3 Administration perspective and their functionality.

<table>
<thead>
<tr>
<th>Use</th>
<th>to...</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>open TM administration preferences.</td>
</tr>
<tr>
<td>(Ctrl+Shift+C)</td>
<td>create a TM server connection.</td>
</tr>
<tr>
<td>(Ctrl+Shift+D)</td>
<td>close a TM server connection.</td>
</tr>
<tr>
<td>(Ctrl+Alt+Home)</td>
<td>undo all segment changes.</td>
</tr>
<tr>
<td>(Ctrl+Alt+PageUp)</td>
<td>undo selected segment changes.</td>
</tr>
<tr>
<td>(Ctrl+Alt+PageDown)</td>
<td>update selected segment changes to the TM.</td>
</tr>
<tr>
<td>(Ctrl+Alt+End)</td>
<td>update all segment changes to the TM.</td>
</tr>
<tr>
<td>(Alt+Shift+Left)</td>
<td>select the previous tag in the source or target segment. The selected tag will be highlighted in red by default.</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>(Alt+Shift+Down)</td>
<td>delete the currently selected tag in the source or target segment or press Backspace on the keyboard.</td>
</tr>
<tr>
<td>(Alt+Shift+Right)</td>
<td>copy the currently selected tag into the source or target segment at the location of the cursor.</td>
</tr>
<tr>
<td>(Alt+D)</td>
<td>select the next tag in the source or target segment. The selected tag will be highlighted in red by default.</td>
</tr>
<tr>
<td></td>
<td>merge two local TMs.</td>
</tr>
<tr>
<td>(Alt+D)</td>
<td>delete selected segment.</td>
</tr>
<tr>
<td></td>
<td>• Mark Same Source Translation Units (TUs)</td>
</tr>
<tr>
<td></td>
<td>• Mark Same Source &amp; Target TUs</td>
</tr>
<tr>
<td></td>
<td>• Mark Same Source &amp; Attribute TUs</td>
</tr>
<tr>
<td></td>
<td>• Mark Same Source, Target &amp; Attribute TUs</td>
</tr>
<tr>
<td></td>
<td>• Mark TUs containing tags</td>
</tr>
<tr>
<td></td>
<td>remove all tags from the selected segment.</td>
</tr>
</tbody>
</table>